1

I have a malfunctioning security app. It's benign, but it has enabled its proactive security mode when I removed it from the device administrators. This is good, and what that means is that it put the phone in sleep mode and overrid the lock screen to require my password. This what it's supposed to do, but it doesn't accept my password.

Here's the situation:

  • I removed the app from device administrators.
  • It put the phone in sleep mode and changed the lock screen.
  • It disabled the menu buttons.
  • I cannot exit the screen without entering my password, which it does not accept.

So my plan is to force stop the app, like you can do in iOS. For obvious reasons, I cannot enter the settings app and force quit the app conventionally.

  • Is USB debugging enabled? Have you tried the "swipe from bottom" gesture to make the navigation buttons reappear? What Android version are you on? – Dan Hulme May 12 '16 at 12:00
  • @DanHumle. I did not have USB debugging enabled. The buttons are hidden in such a way that they still take up space (the black region is still there), but I cannot see them or press them. I am running Android 4.4.4. – latias1290 May 12 '16 at 13:11
1

If your USB Debugging is enabled, the you can force close an app using ADB.

adb shell am force-stop com.my.app.package

This command will force close the application.
But you need to know the specific package name. If you are not sure about the package name please google for Application's apk file, u can easily find package name there. In case you are not familiar with ADB at all please use installer described here

  • I managed to solve the issue by using the online tools that the security provider offers, which apparently doesn't require Device Administration status. But I'm going to accept your answer anyway, as I knew about that command and should have solved my issue if I did have USB debugging enabled. – latias1290 May 12 '16 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.