1

I have an galaxy s4 i33 that I need to have upgraded for work (or buy a new phone.)

On both windows and Linux I can type "adb reboot bootloader" to open the bootloader.

However, in windows:
-Odin Crashes.
-ADB can only find the device when it is turned on normally
-Fastboot says "waiting for device"... forever.
-(Did not try fastboot devices in windows.)

In Linux:
-Fastboot can NEVER find the device.
-ADB can only find the device when it is on normally

'lsusb' looks like this when the device is turned on normally:

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 0480:a007 Toshiba America Inc External Disk USB 3.0
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 413c:2107 Dell Computer Corp. 
Bus 005 Device 002: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 076: ID 04e8:6860 Samsung Electronics Co., Ltd Galaxy (MTP)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

But looks like this with the bootloader screen on the phone:

Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 004: ID 0480:a007 Toshiba America Inc External Disk USB 3.0
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 003: ID 413c:2107 Dell Computer Corp. 
Bus 005 Device 002: ID 046d:c404 Logitech, Inc. TrackMan Wheel
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Thanks for any help, I'm really running out of things to try here. (Could I still get to the bootloader screen if it were locked?)

  • What does the Device Manager show in Windows? Is there a device with an error? – Matthew Read May 12 '16 at 22:14
  • It appears normally in device driver when booted. It displays nothing that I can find to associate with the phone when it is in download mode. – user1833028 May 12 '16 at 22:26
  • Oh wait, hang on, we're talking about a Galaxy S device. They don't have fastboot mode, they have Download Mode. What version of Odin are you using? Have you tried Heimdall? – Matthew Read May 13 '16 at 3:58
  • Heimdall can't find it either. I figured out I need to use 3.10, that can at least download stuff... not that I've managed to install safestrap yet... – user1833028 May 13 '16 at 4:01
  • It kind of sounds like the device isn't working properly while in download mode. Not sure how to fix that! – Matthew Read May 13 '16 at 4:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.