1

Backstory: For years I've been using android devices to type in multiple languages. At first I had to use an app like AnySoftKeyboard or fiddle with android settings every time I wanted to switch languages, which was quite annoying. At some point, possibly soon after I acquired a Logitech Android Keyboard, I accidentally pressed Ctrl+Space and was immediately presented with a popup Toast message: Hebrew.

So I discovered that I could switch languages with Ctrl+Space. At first I thought it had been a CyanogenMod update, but later that conclusion appeared to have been a mistake...

Now that keyboard is in its last life, so I got two new ones, both from Logitech: The K480 and the MK270.

Problem:

The K480 is a Bluetooth Multi-Device keyboard. That feature works well, but Ctrl+Space does nothing. The keyboard does have a built-in language switching button, but it only works on iOS and MAC. Other options such as Shift+Alt and several other permutations do not work either.

The MK270 is a wireless Keyboard/Mouse combo officially for Windows PCs. It comes with a tiny USB wireless receiver, which I plugged into my phone with a micro to normal OTG USB cable, and the keyboard and mouse work just as expected... But again, Ctrl+Space and other combinations do nothing.

More Details:

I should mention that I'm using an LG G2 running a custom build of CyanogenMod based on Android 6.0.1. I'm using the SwiftKey app for the keyboard in lieu of any of these, but I don't think that should make a difference.

If I connect all three keyboards to the G2, the android keyboard can switch the language for itself, but the K480 and MK270 still type in English even when the Android Keyboard is typing in Hebrew.

I also paired the keyboard with a friend's Galaxy S5, and it immediately prompted him to choose a keyboard layout for it. He can choose Hebrew and then it works on his phone in Hebrew, but again none of the keyboard shortcuts will change that.

Question:

How can I switch betweeen keyboard languages on the G2 from either keyboard?

1

on K480 try holding "right shift" and use "right ctrl" to toggle languages

0

Android keeps track of the language settings for each keyboard separately. Therefore, you need to enable the additional language for the second keyboard, and then you'll be able to switch languages with android's default Ctrl+Space.

You can add languages for any currently connected keyboards by selecting the keyboard in Settings -> Language and Input and then selecting the appropriate language from the languages menu.

-1

Hold right shift and then press spacebar

  • what's the deal with downvotes? it works – ishidex2 18 hours ago

Not the answer you're looking for? Browse other questions tagged or ask your own question.