4

My phone is a Samsung Galaxy Grand Prime and it says I'm connected to the wifi, but none of my apps actually work. I get notifications of the apps, but when I click the app it says "network connection problem" or "please check your network connection". The wifi works on everyone device in my home except my phone.

  • Does your phone work on other Wi-Fi networks? Has it worked on your home network previously? Are you using a firewall or ad blocker on the device? – Matthew Read May 13 '16 at 21:46
  • No, my phone does not seem to work on other Wi-Fi networks. Yes, it worked on my home network just an hour before it stopped and no, i am not using a firewall or ad blocked on the device. – Maple May 13 '16 at 23:41
  • That's odd. I'd suggest rebooting the phone, if you haven't already. – Matthew Read May 14 '16 at 1:09
2

There are many ways you can use to get rid of this issue and Here is how I could fix this issue:

We will first try the easiest checklist and then go to advance options later.

  1. Reboot your phone and check if it works.
  2. Have you installed any Anti-virus apps? If yes, try uninstalling it and check if it works.
  3. Boot into Safe mode and check if it works.
  4. Clear app data by going to Settings > Application Manager and that particular app.

Hopefully the above method does work for you, If not follow the instructions below.

Modify Network Configurations:

  1. Go to Settings > WiFi Networks
  2. Tap and hold for 2-3 seconds on the network your device is connected to.
  3. Choose "Modify network config"
  4. Further tap "Show advance options"
  5. Finally set proxy settings to None

Hopefully this fixes the issue, If not follow the 2nd method.

Factory Reset Method This method will wipe the data stored on the device so make sure you've already taken backup of important files.

  • Go to Settings
  • Under the personal tab, choose Backup and reset.
  • Finally I am sure you should have everything working fine.
0

This is most likely a router problem. The WiFi network exists, but there isn't an internet connection. Restart your router and check all the cables. If it still doesn't work contact your ISP...

0

Try turning off any VPN connections in your settings. If you're using opera Max for example. I did this and WiFi connection was back to normal.

0

I deleted an Anti-virus app and it worked straight away. I had this problem for a while and this fixed it.

-1

Rebooting fixed this for me. You should also check that your time and date are correct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.