0

My external SD card seems to be broken. I removed it and inserted a new one.

Now the apps don't work any more. That's all right.

But: I can't uninstall or re-install the apps any more.

If I try to, then the app store seems to crash. I just get the message "App store terminated" (translated from german to english).

It's ok that the data from the sd card is lost.

But: How to get the apps working again?

  • Have you tried uninstalling them via Settings › Apps (the internal app manager)? Another option would be using adb uninstall (from your computer, if you've installed ADB stuff) or pm uninstall (from a terminal app, most likely requires root). – Izzy May 15 '16 at 10:56
  • Yes, I have tried to uninstall via "Settings › Apps". I don't know what adb uninstall is. – guettli May 16 '16 at 8:20
  • If you don't know what ADB is, it's unlikely you have it installed (for a short intro, please see our adb tag-wiki and ADB for end-users – it's a very useful tool, I wouldn't know what to do without ;) So have you tried pm uninstall (requires the app's package name as parameter, e.g. pm uninstall com.foobar.app)? Did it work? Is your device rooted? – Izzy May 16 '16 at 12:15
  • @Izzy, not the device is not rooted. Does adb work without root access? – guettli May 17 '16 at 8:04
  • Yes, the ADB daemon runs with enhanced privileges, so adb uninstall com.foobar.app should work. To avoid unnecessary large installs, you could take a look at my answer here for a minimal installation. – Izzy May 17 '16 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.