1

I am using a Nexus 10 Tablet( Android 4.4.4) . I have 3 PCs where I was already doing android development and one new PC on which I started today. All are windows 7 64-bit Service Pack1. The only difference is that of the 3 older PCs, one is DELL and two HP whereas the newer PC is lenovo ThinkCentre

On the PC which I got today, I am using the same android-sdk, same google_usb_driver(version 11.0.0) and the same platform tools(for adb--adb version 1.0.32), however in my newer PC, I am not able to go into adb shell. The difference I see is that in my newer PC , I do not get the popup asking "Allow USB debugging" and when I do "adb devices", it shows the device as unauthorized. Also when I do "adb shell", it gives the error message "This adb server's $ADB_VENDOR_KEYS is not set".

I went through various forums and tried the following: 1) Turning OFF and ON usb debugging and trying. 2) Doing "Revoke USB debugging authorizations". 3) Restarting my PC. 4) Deleting the C:\Users\UserName.android folder

However none of these worked. Also as I mentioned, it works absolutely fine on all the other PCs with the same device. This would indicate that something is missing/wrong in my newer PC. One thing I was wondering is that when the dialog to "Allow USB debugging" comes up, it mentions that "The computers RSA key fingerprint is:xyz". Could it be that my new PC does not have some openssl or something like that which is causing some issue? Also in my older PC, the .android folder has "adbkey" file, which is not present in the .android folder for the newer PC, could this in anyway lead to the problems or is it just a symptom of the problem and not the cause?

Also please note that in the newer PC, I can connect devices with android version below 4.2 (that is the devices with do not require authorization). Therefore as I said earlier, I think the root cause for the problem is that in my newer PC, I do not get the popup asking for authorization

  • I had the same problem. Try to use different drivers (even if the same drivers work on another PC), this solved my problem somehow. – Benjamin H. May 17 '16 at 8:43
3

I also got the same issue in my lenovo mobile. But when i deleted the .android folder in the home directory, my problem is solved.

For me the issue is the adb don't have enough permission to read the rsa key to communicate with the device. When we run adb server it'll create a folder named .android(Linux - /home/--username--/.android, Windows - C:/Users/--username--/.android) in the home directory of the current user which contains the private and public rsa keys used to communicate between the devices.

When I check the .android folder, it is assigned with root permission(I am using Ubuntu 16.04 and I don't know how its assigned). So when I try to run adb start-server it is trying to create .android folder. But the current folder with root access is not allowing this to create the adb keys. That's why its failed.

So I deleted the folder using below command. Use a particular method to delete the folder based on your operating system. Below I mentioned for linux.

sudo rm -rf .android

Then restarted the adb server using below command.

adb start-server

Now It created the .android folder and the rsa keys with the current user permission. Once done this I got the Allow USB debugging dialog in my mobile.

I know its too late. But I'm mentioning here because it'll help someone in the future.

protected by Community Apr 13 '17 at 23:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.