4

My Samsung Galaxy Note 3 has developed an interesting fault.

It happened one evening, after the phone shut down due to low power. Its symptoms:

  1. It has deleted (or appears to have deleted) most of the applications - including system applications. For example, I had at least 3 browsers installed, I now have none.
  2. The majority of other applications do not work, for example: Messages still appears, and I can view a listing, but as soon as I try to access a message it says "Unfortunately, Messages has stopped". Less than a second later, that dialog also disappears, without me having to press OK. The Google Play Store app shows a blank white screen, then crashes - this time, without the dialog. Apps that were received through Amazon Underground (those that still appear) complain that Amazon is not installed and logged in.
  3. I have a notification in the notification area that says "Get Google Play services / Google Play Music won't run without Google Play services, which are missing from your phone" - and again, when I press it, it transitions to a blank white screen which then promptly crashes, dialog-less.
  4. Phone now takes at least 5mins to boot, every single time.

So my question is: what could cause this? I've resisted rooting this phone, so I never (theoretically) had the capability to delete these files.

I intend to try and reflash GApps etc, then probably install a cynogen or something - if my phone is imploding even with a stock rom, I may as well have fun. And I have backups of most of the important stuff. So I can rectify the situation - the question is purely what could cause this.

Would a Google Play service update during the phone shutdown be enough? (I guess no...)

Maybe registry corruption of some sort? (My best guess for the extended boot time)

And has anyone ever succeeded in doing this through some intentional action?


[Edited]: Small update: Firstly, I forgot to mention, a large portion of my contacts seem to have disappeared too. So I can see the phone numbers in my Messages, rather than their names, for probably about 80% of people. I guess this might be because it cannot access Google for some reason?

Secondly, I have now tried reinstalling Google Play Services (installed using adb install) and nothing seems any better. Have looked at the logcat, and I suspect that chromium webview is the real cause of many of the above symptoms. Downloading now.

[Edit 2] Also, forgot to mention, most of my contacts disappeared. They were mostly synced with Google though, so when I installed a new rom, they mostly reappeared - I guess with the exception of recent contacts that hadn't synced.

But yes, crisis averted (more or less). I now have a Samsung Note 3 pretending to be a rooted Samsung Note 5 and am pretty happy, but still curious about what went wrong.

  • 2
    If you're willing to say good-bye to any data possibly still saved on the device, I'd recommend a factory-reset. My guess here would be a corrupted package list, which would be cured by that. No guarantees, though. – Izzy May 17 '16 at 16:02
  • @Izzy: I'll be doing a factory reset too, though other posts seem to indicate that if any of the apps truly have been deleted, then this will not fix it as /system is assumed to be incorruptible :) Feel free to put your guess as an answer, also, do you know of any way of forcing Android to rebuild the package list? – user208769 May 17 '16 at 16:09
  • Not sure. If your device were rooted, and you'd have a custom recovery, I'd tried clearing the Dalvik/ART cache and renaming the package list (to keep a backup) – in the hope this would force Android to recreate it. I'd also wait for some other answer/suggestion before performing a factory reset, so maybe your data can be saved (if any are needed and you don't have a recent backup). Ping me if there's no better suggestion within a few days, I'll expand my suggestion to an answer then. – Izzy May 17 '16 at 16:17
1

The same thing has happened to me.

The fact I also have a Note 3 with exactly the same symptoms makes me believe it is a faulty system update or other service installation/upgrade error.

Google Play Services v7.3 (according to https://play.google.com/store/apps/details?id=com.google.android.gms but maybe it's 9.0.82 or 83 or something) rolled out from May 16, I reckon this is the culprit.

I woke up to my phone complaining the same error: "Get Google Play services / Google Play Music won't run without Google Play services, which are missing from your phone".

I managed to install Samsung Internet for Android via Samsung Galaxy Apps.

I then downloaded a Google Play Services apk after searching Google for one and installed it.

That kinda got Google stuff working again, but I had to reinstall a lot of my apps. Authenticator still works thank god.

Boot still takes ages, and every time Google Play Services is gone again.

  • I failed to look at the comments for that update, I'm guessing this is the problem. Lots of people seem to be complaining in the comments about this package update breaking their phone, though it sounds like this happens with every update, and lots of Google-hater noise. I rooted my phone and installed a phronesis rom, as I didn't want to continue with a crippled phone - but thank you, my worst fear was that my flash had developed a fault, and that seems more unlikely now – user208769 May 25 '16 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.