0

I have downloaded an apk from a site, but now I cannot install it; when I'm trying to install, it just returns me an alert / toast message with: Sorry, no application available

The Package Installer.apk is located in its default location (i.e., /system/app/Package Installer.apk)

I have tried this one time, that I installed Package Installer through Package Installer ...

I have found a solution on the web (from XDA):

Go to Settings > Application Manager > All > Package Installer.

Clear its cache, its data, force it to stop, then reboot.

But, it doesn't work (for me) ...

I have a custom recovery installed: TWRP, and of course, my phone is rooted. Does this affect the Package Installer?

I had also tried using Third Party "App / Package Installer", but that doesn't work either (it just lets me pick apks from phone's storage,then install it through Package Installer).

PLEASE HELP!!! ☺

  • Are you sure that the downloaded apk really has the ".apk" file extension? Can you install other downloaded .apk files? – benjamin May 18 '16 at 10:21
  • Yes, it has that ".apk" extension. However, I cannot install other apps / apk; but, I can, using the Play Store. When I install an apk, it just returns me that toast message: "Sorry, no application available". – Lloyd Dominic May 18 '16 at 10:24
  • Which file manager app are you using? Have you tried a different file manager? – Firelord May 18 '16 at 11:44
  • Sorry for the late replies. Anyways, I think it doesn't matter about the File Manager you are using; I've used ES File Explorer, navigated to the folder where the apk is, then I installed it, but no luck; same thing happened with my stock File Manager. I think the problem is on my stock Package Installer; if you would look at yours (Rooted phone and third-party file manager only): /system/app/Package Installer.apk is where that apk installer located. – Lloyd Dominic May 20 '16 at 14:11
1

I can't believe it actually worked for me; I just tried it and it worked. Here's the solution:

  1. Move / Copy Package Installer.apk as well as the .odex file of Package Installer from /system/app to /sdcard or whatever folder you may want to copy the file to.

  2. Delete the Package Installer (apk and odex) from /system/app if you've copied it.

  3. Reverse the first step. That would be, copying the copied file and pasting it to /system/app or moving it on to /system/app.

  4. Reboot.

0

TWRP is a recovery not a ROM*

My problem was when im still on 4.4 kk and all I do was to restart. if the install button doesnt work except for cancel. But not this kind of problem that shows "No app. available"

I didnt experience the installer allows you to tap install button but fails. It means probably your storage is full or something on the system is bothering the installer. Please detail your question. IF this will bother your storage try backing up: 1-Reset Device (Factory reset) 2-Reboot 3-Clear cache 4-Clear dalvik and cache 5-Reflash ROM

If none of these work please comment it, itll research this further on XDA forums.

  • Oops! My fault! I still don't know (before) that TWRP is actually a recovery, and not a ROM. Anywags, editing the question ... And, that "No App Available" occured when I accidentally installed the Package Installer.apk through Package Installer itself. That's why, it caused errors, and it showed that "No app available". – Lloyd Dominic Feb 12 '17 at 11:16
  • Its fine, people does mistakes. Its somehow like a Package Installer-ception, but if im gonna analyze it the package installer is probably terrorizing the original package installer (corrupts it). Ill recommend you to factory reset because it will create the original package installer and goes back to normal state. – NeonzYT Feb 12 '17 at 11:21
  • I already solved, and found out a solution to my problem. The Package Installer is now working fine. See my answer! – Lloyd Dominic May 5 '17 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.