I have a Google IO Samsung Galaxy Tab that has decided it no longer wants to boot properly. It just constantly goes from the 'SAMSUNG' logo that flashes a couple of times to the stars and lines animation that goes back to the logo. It does the startup sound on the first iteration only.

If I hold the power button while it is doing this, it goes to a screen that just says

 Entering upload mode...
     Upload_Cause:  undefined

and hangs there. Holding the power button again will take it back to the boot loop. In order to get it to actually power down properly I need to just wait for it to run out of battery.

I assume I'll have to stomp the firmware or something, but I'm not sure how to actually go about it. My computer is a Mac, so instructions that work there would be good, but if necessary I should be able to commandeer a Windows machine for a while.

Also the colour rendition became bad leading up to this problem (this is a reasonable approximation of the situation - it is clearly not right, but the image is still identifiable). I'm not after a separate fix for this problem (yet) - if it's still a problem once the bootloop is fixed I'll be back, but I figured it might be a relevant datapoint.


I've tried to get clockwork recovery on it, by following these instructions, but after actually getting the image file on there (end of section 4), it comes up with the 'Samsung Galaxy Tab' logo with an open padlock image at the bottom, and then goes back into the animation -> 'SAMSUNG' logo loop. Sooo, not that useful...

2 Answers 2


I had the very same problem with my IO tablet (samsung logo loop, sometimes the upload_cause screen, but never actualy booted). Took me a lot of try/fails before I found a working solution. And this is it: You have to reflash not only the stock rom, but the stock bootloader too. I followed this tutorial and my tablet is working without a hitch! Good luck!


  • The odin in the zip file on that page didn't actually work for me, but the other files and steps were all good with a different odin I'd already downloaded
    – Cebjyre
    Dec 16, 2011 at 9:02
  • @Cebjyre you should give a link to the zip you used so this helps others with the same problem.
    – jmort253
    Jan 23, 2015 at 16:48

Have you tried a factory reset by fiddling the power and volume buttons?

Reset Galaxy Tab with Hardware Keys

If Android OS is not loading then you can hard reset Galaxy Tab using hardware Keys combination.

  1. Make sure tab is turned off (press and hold the Power button for about 10 seconds to turn it off).
  2. Press and hold the “Volume Up” and “Power” buttons at the same time, when logo appears on the screen release the “Power” button and continue press the “Volume” button
  3. When recovery screen appears use “Volume Up/Down” buttons to navigate and select “wipe data / Factory reset” by pressing the “Home” or “Power” button (Depends on Galaxy Tab model).

(I got this from http://www.trickyways.com/2010/12/how-to-reset-samsung-galaxy-tab-to-factory-settings/ and have not actually tried it myself.)

  • Based on the date of the article, I assume this would work with the model before the IO version, but on mine it doesn't actually do anything. Using the 'Volume Down' button instead gets to a screen with a USB icon and an android dude digging as the options, which seem to be related to different ways of getting new firmware onto the device, so now I'm exploring this path (there doesn't seem to be much in the way of Mac love though)
    – Cebjyre
    Oct 17, 2011 at 0:46
  • On mine it doesn't actually do anything either.
    – MountainX
    Sep 11, 2012 at 19:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .