1

I have a nexus 5 which has ubuntu touch on it. The OS is broken and won't boot. I am trying to flash CyanogenMod to it, i've hooked it up to my ubuntu server, and am following this: https://wiki.cyanogenmod.org/w/Install_CM_for_hammerhead

However when i get to the point of adb push to get the firmware onto the phones local storage i get:

error: device unauthorized. This adb server's $ADB_VENDOR_KEYS is not set

And on adb devices it says unauthorised. Since i have no booting OS on this phone, how can i get around this shit so i might complete my flashing process?

I've installed the Cyanogenmod recovery environment successfully and am able to boot into this.

  • Download TWRP for your N5 and use the Fastboot install method described there. Boot into TWRP. You should have a working ADB available then. – Izzy May 19 '16 at 16:21
0

Issues like this this are often corrected by returning to a "known good configuration" before processing additional changes.

I would suggest returning to the current official Google firmware via fastboot, then verify the device is booting and operating properly, then you can flash custom recovery and install a third party ROM such as CyanogenMod.

Instructions and factory images with flashing scripts are available directly from Google at their Factory Images for Nexus Devices page.

  • I ran the flash_all.sh script from that google link and it just hung (fastboot on phone just showed downloading...) and now anytime i run a fastboot command other than devices, it just hangs forever. Any idea what could be causing this? It does show up on devices, and shows itself as unlocked on the phone with secureboot on. – user3407675 May 19 '16 at 21:43
  • @user3407675 Since you said your running the sh script, I assume Linux... Are you running it with root permissions as su? – acejavelin May 19 '16 at 21:48
  • Yeah, i've logged into the box as root. I found if i do oem lock then unlock it did something useful. I guess it formatted a corrupted or incomplete image which was flashed, as now this has brought it back to working android. Thanks, i'll mark it as solution. – user3407675 May 19 '16 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.