0

I've already read the answer of this similar question here but in the first answer in step-6 it is not asking for replace the application because I've deleted it from my phone and it is not disabled. And the second Answer is for non-rooted devices. So this is not duplicate of that question.

I've also tried to factory reset my device but it is not working.

I've also tried to download play store from the browser. But when I installed it and tried to update it, it shows Google Play Store Stopped Unfortunately.

When I try to open apps like YouTube, It shows the message YouTube relays on Google Play Services, Which is not supported by your device. Contact the manufacturer for assistance.

How can I install it again? Is there any solution for this? My device is SONY XPERIA C 2305, Android 4.2.2 Jelly Bean.

  • Providing that you have a custom recovery, visit opengapps.org and find the appropriate GApps package for your Android version (if any). Then, flash it from recovery. – Death Mask Salesman May 19 '16 at 17:18
1

If you are running a custom ROM, you will need to re-flash it along with the corresponding GApps package.

If your phone is unmodified stock (beyond rooting) you will need to re-flash the original phone firmware as described in this guide, and optionally re-root it.

Quote of the guide from the above mentioned post:

*Download wmshua
*Download ftf file of 16.0.B.2.13 or ftf file of 16.0.B.2.16(preferred) (these files are specifically for Sony Xperia C C2305), If you have any other deivce, download their firmware files.
*Install Sony PC Companion
*Switch Off your mobile phone and get the Original USB Cable pf your device
*Open Wmshua and then Connect your device to PC pressing the Volume Down Key
*As Soon as connected Wmshua will install device drivers (taking about a minute), then go to "Flash" option and select the ftf file from there. And click on Start. It will take about 10 minutes or maybe more to flash the file. Wait Till It Completes.
*Now your device is ready on 16.0.B.2.13 or 16.0.B.2.16 whichever you selected

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.