I don't want all my storage as adopted storage, so I was wondering how I can split it into 1 part adopted storage and 1 part normal file storage (what Android calls "portable storage").


You don't need to root your device but the device i done this with is rooted

  1. You need to enabled Developer Options.
  2. Enable the USB Debugging option.
  3. Make sure your SD card is formatted as portable, then get the adb executable (see our adb tag-wiki for details).
  4. Connect your device to your PC and run the adb devices command. If your device is connected correctly you will see your device listed in the output.
  5. Run adb shell sm list-disks adoptable. This will show you the list of disks that can be used for what we want.
  6. For my device it showed me disk:179,128 so i ran adb shell sm partition disk:179,128 mixed 80 on my 32 GB AS card. It gave me 5 GB as adoptable storage and the rest for other uses. (This will format your SD card.)
| improve this answer | |
  • Does this really require root as the command to set up adoptive storage in the 1st place does not? (sm partition disk:foo,bar) – Barleyman May 24 '16 at 13:31
  • @Barleyman Well not really but my device is rooted and i didn't test this with none rooted devices so if you like you can try and let me know if you got any error – poqdavid May 24 '16 at 13:40
  • 3
    I did actually yesterday and today on my Galaxy S5. I didn't use the mixed type but at least the sm partition disk:foo,bar private works just fine without root. Migrating from lollipop with Link2SD to Marshmallow with adoptable storage is a bit of work. Gotta do clean install and copy titanium backup files to PC & back and repartition the sdcard on pc and later on the phone. Also titanium backup does not realize phone storage is running out so you'll have to fight past dialogs to move a single app to sdcard to make enough room that you can use apps2sd to migrate the rest.. – Barleyman May 24 '16 at 13:48
  • Works perfectly on Moto E with CM13 Temasek 10.4. Thanks! – Fernando Kosh Aug 7 '16 at 1:30
  • 1
    On my device the sm partition disk: disk:179,128 mixed 80 command returned the usage of the command, maybe it's because of the custom ROM, but I replaced the comma with an underscore and it accepted it - eg. sm partition disk: disk:179_128 mixed 80 – samdd Apr 17 '17 at 11:54

poqdavid's answer is correct.

In addition though, you might get the error that your SD card on your device storage is corrupted. If so follow these steps.

After you have partitioned the disk and while your SD card is corruped enter In the terminal the following:

$> adb shell sm list-volumes all

Which will list your volumes, for example:

private mounted null
public:179,1 mounted B5B1-140C
private:179,3 unmountable null
emulated mounted null

Then enter the following replacing 179,3 with whichever disk numbers you are given:

$> adb shell sm format private:179,3

$> adb shell sm mount private:179,3

Now your SD card in device storage should be properly mounted and your portable storage will still be there.

This worked on my LG G5 and should work on the S7.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.