4

I have a Moto G 2013 (XT1033). The device does not boot successfully - only shows the logo and then just shows a blank screen. So I tried to install Cyanogenmod hoping it might work out. I have unlocked the bootloader.

I tried installing TWRP recovery image (3.0.2.0) from TWRP official site using the command

$ fastboot erase recovery
erasing 'recovery'...
(bootloader) Erase allowed in unlocked state
OKAY [  0.046s]
finished. total time: 0.046s
$
$ fastboot flash recovery twrp-3.0.2-0-falcon.img 
target reported max download size of 536870912 bytes
sending 'recovery' (9488 KB)...
OKAY [  0.331s]
writing 'recovery'...
OKAY [  0.175s]
finished. total time: 0.507s

And the device shows the following text:

cmd: getvar:partition-type:recovery
cmd: erase:recovery
cmd: getvar:partition-type:recovery
cmd: getvar:max-download-size
cmd: download:00944000
cmd: flash:recovery
Mismatched partition size (recovery)

Bootloader Screen during Recovery Image Installation

When I boot into the recovery, it displays a Unlocked bootloader warning, then a blank screen for 2-3 seconds and then an image of resting android bot with a red exclamation over its belly, with "No command" caption.

No Command Screen

No TWRP Recovery Screen.

Then I pressed Vol UP + Power button for 2-3 seconds and that displayed the Android system recovery screen. Now I selected "apply update from ADB". Then I tried the following command:

adb sideload cm-12.1-20151117-SNAPSHOT-YOG7DAO1K9-falcon.zip

I get the following error in the Android System Recovery screen:

E:failed to verify whole-file signature
E:signature verification failed
Installation aborted

Sideload failure due to Signature Verification failed

The Cyanogenmod zip file is not corrupted since the SHA1 hash is the same as the one provided in Cyanogenmod downloads page. Please help me to install Cyanogenmod on Moto G (XT1033).

Thanks in Advance

  • 2
    You cannot side load zip files through stock recovery which are not signed by your vendor, so don't bother with side load. We can discuss details later. Now, can you rename that TWRPimage to recovery.img and from bootloader mode issue the command fastboot boot recovery.img? – Firelord May 22 '16 at 9:53
5

As it's obviously the stock recovery you've used to flash CM, that won't work as it will do a signature check and thus reject the ZIP as being invalid. So here's what you do instead:

  1. put cm-12.1-20151117-SNAPSHOT-YOG7DAO1K9-falcon.zip onto your device's SD card
  2. boot into bootloader
  3. now boot (not install) TWRP: fastboot boot twrp-3.0.2-0-falcon.img
  4. TWRP will show up on your device. Chose "apply update from SD card", navigate to where you put your CM .zip, select it, confirm

Worked for me, though on a different device.

  • Just saying wouldn't it be better to install and boot? Because if anything goes wrong you can always go back to recovery without being tethered to a pc – lolreppeatlol May 23 '16 at 2:57
  • @lolreppeatlol you've noticed that OP tried that and failed? – Izzy May 23 '16 at 5:15
  • 1
    Giving error downloading 'boot.img'... OKAY [ 0.344s] booting... FAILED (remote failure) finished. total time: 0.359s – Laxmikant Dange Sep 1 '16 at 21:26
  • 1
    @LaxmikantDange Bootloader locked? Then it will fail. – Izzy Sep 1 '16 at 21:29
  • 1
    I unlocked the bootloader then it worke, Thanks. :) – Laxmikant Dange Sep 2 '16 at 5:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.