1

I learned that app factory apps should run in the background no problem, but if that's the case, I'm wondering why the simple app I created randomly restarts when it includes a 30 minute waiting action. When I take it out, it works (starts does its job and stops in a matter of a few seconds). But I'd like it to do another action after 30 minutes and that's when it keeps restarting several times during that 30 minute period. (And by restarting I mean that it re-executes the actions listed before the 30 min wait.)

Any suggestions how to stop it from doing this (or an explanation why it is doing this)?

Here is the XML of a MWE. (Remember that you need to export this as an app in order to reproduce the issue. Running it in Tasker seems to work fine.)

<TaskerData sr="" dvi="1" tv="4.8u4">
<Project sr="proj0" ve="2">
    <cdate>1463986944702</cdate>
    <name>MWE</name>
    <tids>7</tids>
    <Img sr="icon" ve="2">
        <nme>cust_warning</nme>
    </Img>
</Project>
<Task sr="task7">
    <cdate>1463986956333</cdate>
    <edate>1463987117854</edate>
    <id>7</id>
    <nme>MWE</nme>
    <Action sr="act0" ve="7">
        <code>523</code>
        <Str sr="arg0" ve="3">Start</Str>
        <Str sr="arg1" ve="3"/>
        <Img sr="arg2" ve="2"/>
        <Int sr="arg3" val="0"/>
        <Int sr="arg4" val="0"/>
        <Int sr="arg5" val="3"/>
    </Action>
    <Action sr="act1" ve="7">
        <code>30</code>
        <Int sr="arg0" val="0"/>
        <Int sr="arg1" val="0"/>
        <Int sr="arg2" val="30"/>
        <Int sr="arg3" val="0"/>
        <Int sr="arg4" val="0"/>
    </Action>
    <Action sr="act2" ve="7">
        <code>523</code>
        <Str sr="arg0" ve="3">End</Str>
        <Str sr="arg1" ve="3"/>
        <Img sr="arg2" ve="2"/>
        <Int sr="arg3" val="0"/>
        <Int sr="arg4" val="0"/>
        <Int sr="arg5" val="3"/>
    </Action>
    <Action sr="act3" ve="7">
        <code>137</code>
        <Int sr="arg0" val="0"/>
        <Str sr="arg1" ve="3"/>
    </Action>
</Task>

  • I'm not sure if the entire XML is necessary. To reproduce the issue try the following MWE: set up a single task consisting of 4 simple actions of which the second one is "Wait 30 minutes". Let's say, the first one issues a notification saying "start" and the third one does a notification "end". The last action is stop. Now export the task as an app and start it. What does it do? In my case, I get multiple "start" notifications before the end notification shows up. – Christoph May 23 '16 at 6:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.