My android device is showing that I am connected to the Wi-Fi network at my community college (where I attend), however, when I try to use anything that requires internet it says there is no internet connection.

screenshot screenshot
Screenshots (click images for larger variants)


  • Clearing cache (as per this TheDroidGuy article)

  • Rebooting to bootloader

  • Rebooting phone

  • Navigated to Google in Chrome

  • Navigated to Google in Firefox

  • Called AT&T store: They gave me 3 options:

    • Try another place and see if there are issues with wifi
    • To update to Marshmallow: Settings > System > About Device > Update Phone
    • Dial 611 to get to Customer Support

I tried the last one. The representative in Iowa ended up "sending an OTA switch", whatever that means. In the middle of him explaining it to me the phone cut out.


I don’t know exactly what info an android-wifi savvy reader would need to be able to help, so I have provided as much info as I could find in an effort to be as thorough and helpful as possible. If any other info is needed, please let me know.


  • Provider: AT&T

  • Brand: Samsung

  • Model Name: Galaxy S6 Edge

  • Model Number: SAMSUNG-SM-6890A

  • Android Version: 5.1.1 (Lollipop)

  • Android Security Patch Level: 2016-04-02

  • Baseband Version: G890AUCS3BPCG

  • Kernel Version: 3.10.61-7277676 (etc...)

  • Build Number: LMY47X.G890AUCS3BPCG

  • Security Enhancements for Android:

  • Enforcing

  • SEPF_SAMSUNG-SMG890A_5.1.1_0046

  • Wed Apr 06 20:28:50 2016

  • Security Software Version:

  • MDF v2.0 Release 3

  • VPN v1.4 Release 5.2


  • Signal Strength: Strong(351Mbps)

  • Security: 802.1x EAP

  • IP Address:

  • EAP method: PEAP

  • Phase 2 Authentication: None

  • CA Certificate: (Unspecified)

  • IP Settings: DHCP

  • Proxy: None


Mercury retrograde -- a time when communication between people can be very confusing and when electronics fail more than others times of year -- was supposed to be over yesterday, but maybe it’s still the 22nd in some part of the world (I’m in Western USA).

Virgo astrology horoscope for today said that I was going to be “tired of having to troubleshoot things”. Immediately afterward I realized my phone was only streaming via mobile and not via the wi-fi network it told me it was connected to.

These may be longshots, but I think they are worth mentioning.

Any help is appreciated. From one soul to another, thank you in advance for your kind assistance.

Namaste & Mitakuye Oyasin

1 Answer 1


Dns probe image no internet error.You can try changing your ip settings from DHCP to static and connecting to GOOGLE dns.

Important: Before you start: Before you change your DNS settings to use Google Public DNS, be sure to write down the current server addresses or settings on a piece of paper. It is very important that you keep these numbers for backup purposes, in case you need to revert to them at any time.

To change the DNS settings: Open the Settings on the device. Select “Wi-Fi”. Long press your current network, then select “Modify network”. Mark “Show advanced options” check box. Change “IP settings” to “Static” Add the DNS servers IPs to the “DNS 1”, and “DNS 2” fields. DNS 1 to DNS 2 to Press “Save” button, disconnect from the network, and reconnect for changes to take effect. Good luck!

  • Thanks for your reply! I'm at school right now, but I will try this later tonight and report back with my results. May 23, 2016 at 21:31
  • This is good information and since nobody else replied I am marking it as the answer. However, for clariity, here is some important information: Nobody at AT&T support was aware of any update, but the day after I posted this it was common knowledge that an update was pushed. Also, I was able to connect to wifi on my phone the next day at school without a problem. Jul 27, 2016 at 14:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .