1

I tried to do a backup from within my custom recovery (CWM or TWRP) but it failed due to a lack of space. Since then, my phone will not complete the boot process but remain on the boot animation for hours. (In case it matters: it's not a boot-loop in the strict sense as the phone does not go through the boot process over and over again. It's just stuck and doesn't go all the way through.)

I have tried wiping dalvic-cache and cache. I removed the memory card (to see if it had gotten corrupted and was blocking the boot process). I even re-flashed my ROM and GApps, but to no avail.

Since I did not flash anything or really make any changes to the phone at all, I am stubbornly refusing to believe (as many posts and videos on the net seem to suggest) that the only way to proceed in this situation is to do a factory reset (or some other method like an odin flash) which will delete all my precious data. There must be a way to get this phone going again without losing any data.

2

Stubbornness sometimes pays. Here is what solved the issue for me (and since I did not see this idea anywhere, I'm posting it here): it turns out that the (attempted) backup filled up the internal memory so that there was not enough left to complete the boot process. So I used the file explorer in TWRP 3.0 (Not sure if CWM has one, if not, just flash TWRP) to delete the backup and voilà, the phone boots again.

Obviously, you could also delete something else (make sure you know what you're doing), the point is to free up space on the phone's internal memory. In fact, I actually tried to move the backup to the external SD card but there seems to be a bug that (sometimes) lets the move command fail so what I did was copy and delete instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.