I recently moved to Android 6 and promptly slept in the next day as my alarm clock (Alarm Xtreme) wasn't waking me up.

I search around a bit, disabled the energy setting stuff for that application and went to bed...only to not being waken up again.

I read some more and some people suggested a different alarm app ("Simple Alarm Clock" that apparently should work on Marshmallow). I set up my alarms and then went on to close the application as I always do (rectangle button, push the application window 'out') only to see the little alarm bell icon in the status bar disappear.

I went back to the Alarm Xtreme application, opened it and sure enough the alarm bell symbol appeared. Closed the app and the symbol immediately disappeared.

What is going on there and how do I fix it? Aren't alarms running in the background anymore? If yes why not?

I don't want to always remind me to open the alarm app before going to bed, mostly because I'd forget it half the time.

Oh also because that is mentioned a lot: My phone is always plugged in when I sleep.


4 Answers 4


When you say the little alarm status bar symbol, do you mean up the top left? If so, it sounds like that alarm app is running as a Service rather than registering with the system's AlarmManager.

When you swipe the app away from the multitasking view, you are killing the Service. More details

I have only a few suggestions:

  1. Ensure the app cannot be optimised to save battery. Settings->Battery->Battery Optimisation (Overflow menu). Ensure app is displayed in Not optimised section.
  2. Don't swipe the app to close it. This typically isn't needed on modern Android phones. Though really, I'd still not trust the alarm as the system can clean up apps whenever it needs to.
  3. Use a different alarm app. I use Timely on Marshmallow and have never had a problem with it.
  • well there is a small icon for the app on the left and also a little alarm clock symbol between the 'Vibration' and the 'Network quality' icon. Both icons are disappearing when closing the application. I do expect the left one to disappear, but not the right one. Commented May 26, 2016 at 13:33
  • *edit I hadn't set the setting in the battery manager to allow the Simple Alarm Clock. After I set that both icons stay when I close the application. For anyone reading: You can find set setting under Advanced Settings -> Battery manager -> Protected Apps Commented May 26, 2016 at 13:40
  • 1
    I'll update my answer to make it clear what solved it for you. Commented May 26, 2016 at 13:42

Checkout my alarm app Alarm + Task Logger FREE.

Playstore Link

I have developed this app post Marshmallow update and have circumvented the problem of missfiring alarms due to doze mode.

Besides this it offers more features & customizable options than others. Check playstore description.


The problem with my phone was because of DOZE mode. So I had to go to Battery manager and Allow All applications to run while the phone is locked. It solved my problem.


The default Clock app was only vibrating, no alarm sound. When trying the other "Clock" app of Google, it showed the warning: Alarm is muted. Unmute? after clicking it, the alarm was back.

Solution: Use the volume keys on your phone during the alarm to get the sound back.

And I admit, this little seemingly no-brainer took me one year to find out …

  • Just so you know, if you press a Volume Key and the volume bar appears, there is an arrow on the right side. Press it and 3 sound bars appear, one of which is the alarm one. Commented Oct 25, 2017 at 22:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .