0

Even yesterday afternoon I was being annoyed by Android File Transfer reopening lots of times while the phone was USB connected to my computer. This morning, all of a sudden, my phone seems to not notice being connected to the computer: it's as if I connected it to a charger, it doesn't show the usual "Connected as media device" notification or any other sign of it thinking it is connected to a computer. Except it is. And I have tons of files to get onto that computer. So how can I get that mobile to see the computer?

Update

I tried working my way around this by Bluetooth, but when I click "Browse device" on My computer it goes This device does not have the necessary services or the likes. What does that mean? Is there a way I can send a file from my mobile to the computer?

Update 2

I forgot to mention I would like a way that doesn't lose the metadata (Date Modified, Date Created) during the transfer, as happens with Airdroid (which I have already) and Xender (which I just tried following the answer). Sorry, answerer, but I don't think I'll be using that solution…

Update 3

Magic magic, the mobile is now connected as a media device, or at least says thus. Except Android File Transfer doesn't find it. What can I do now?

Update 4

Magic magic once again, the phone only connects as media device when the earphones are connected to it, and Android File Transfer doesn't see it, earphones or not. So summing up, the media device connection is mysterious, AirDroid and Xender both lose timestamps, which I'd rather preserve, so my files are stuck on the mobile, and trying other ways (Bluetooth and FolderSync) has failed. Here are screenshots of the chat, 1 2 3 4 5 6. If anyone has any idea how to solve my problem of keeping timestamps, or how to get AFT to see my mobile (and that mobile to connect as media device), please comment/answer.

Update 5

I changed cable and everything works fine. I don't think it was just leaving the phone dangling from a 4cm-long cable, but rather the twist I gave it on Thursday that might have caused the problem. So my 4cm cable works for charging but not for USB connection. However, I can't use the other cable instead, because -- nonsensical as it may seem -- I run a (statistically) greater risk of losing a longer cable in Uni than I do with the micro-one I have now. So the problem persists. And even the hypothesis of that twist being the culprit doesn't convince me, since the effect was delayed by at least a disconnection of the cable. Ha-ha! Surprise surprise, I twisted it again, and voilà, everything is fine now! How did that happen?

Update 6

Seems that whether the Computer sees the mobile or not depends in some pseudo-random way on how much I twist that cable :). Not only how much, but like, in what direction I twist it. THis is so strange.

  • 1
    You could try the FolderSync app (via SMB or SFTP, depending on the OS on your computer). As for the "necessary services": it most likely misses the "OBEX" stuff (Bluetooth FTP); but using that, you#ll most likely lose the timestamps as well (and it will be pretty slow, too). – Izzy May 27 '16 at 14:24
  • @Izzy just downloaded FolderSync Lite (non-Lite was to be paid) and how do I use it? – MickG May 27 '16 at 14:32
  • 1
    1) setup an "account" (SMB/SFTP) to access your computer, 2) setup a folder pair to be sync'd (i.e. one folder on your computer, one on the device), then 3) sync them. You can have one-way sync (to xfer only files from the device to the PC or the other way around) if you just want to copy in one direction. See the FolderSync help page for details. – Izzy May 27 '16 at 14:36
  • @Izzy that help page seems only to deal with the wrong type of account. I'm trying to set up an FTP account. What do I put into the "Connection", "Login" and "Advanced" fields of the account setup? – MickG May 27 '16 at 15:10
  • I tried putting my computer's IP address as obtained from the Finder into "Connection" and leaving the rest empty, the account was created, but then the Create Sync Wizard won't let me select the Remote Folder… – MickG May 27 '16 at 15:11
0

Try "Xender Web"

  • Open Xender App in your Smartphone
  • Now see top-right side of the app carefully and click on button to open Connect PC Page
  • Click on “Scan” button and hover your camera to the below given QR code.

    Note : Use Wi-Fi whenever possible, because using it with Mobile-Data will consume your data quickly.

  • See edit. Can Xender keep the metadata someway? – MickG May 27 '16 at 11:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.