I am using Moto G3 TE. I was happy with the 5th version but because the frequent alert for 6th version was killing me, I gave up and updated to Marshmallow. It's been like 8 days and now my mobile is showing issues which I listed below:

  • Home Screen and Recent Apps buttons are not working. Though they show effect on touch but nothing happening.
  • I am unable to see Quick Settings through swiping from up to down
  • Pattern lock is not visible, when I press the lock button on side. My phone can be easily access by anyone now.
  • Moto's special feature of showing notifications on screen when I touch the phone, isn't working.

I am assuming the problem might be because of the upgrade to Marshmallow.

Other possible problems could be (considering today's activities):

  • Trying to upload around 2GB of data to Google drive. (When I tried this, unknowingly whole drives' data was downloaded to my phone until there was no space and then the "DU battery saver" app crashed, this is the first issue I observed)
  • Giving some security permissions to "CM Security" app.
  • Inserted micro USB pen drive and moved some files from internal storage to pendrive through inbuilt explorer.

What I tried (in sequence):

  • Uninstalled "DU battery saver" app.
  • Uninstalled "CM security" app.
  • Installed "Clean master" app.
  • Reinstalled "CM security" app.
  • I restarted my phone several times but no use.
  • I take off the screen glass from the screen, still no use. (unfortunately, the screen glass broken)
  • Tried to reset factory settings but it seems the "reset" button is disabled.
  • It seems I even can't able to do "Hard reset" which I tried by holding the lock and volume up button. The phone just gets restart. It is not that I want to do this but I just thought to give it a try.

PS: My phone is six months old.

Please help.

  • Facing exact same issue with Motorola X-Play May 30, 2016 at 13:54
  • 2
    @NileshMendhe Run it in safe mode. Press the power button till you see "Power off" on screen. Then press and hold the "power off" button visible on screen. You will be prompted to restart your mobile in safe mode. Run it in safe mode. According to experts, it happens because of stupid third party applications. When you run on safe mode, run each third party app and check which was causing the problem and uninstall that app.
    – Mr_Green
    May 30, 2016 at 13:56
  • It only showed me "Zen UI Launcher " other than standard apps in color code. Uninstalled it ! Still not working . May 30, 2016 at 14:13
  • 1
    @NileshMendhe Here is the direct link which explains the same. Actually, I had asked the same question on motorola forums. Here is the link. The service guy asked me for IMEI number but due to my own suspicion, I didn't provide it. You will understand how I fixed the issue if you read that post (Don't try that!!).
    – Mr_Green
    May 30, 2016 at 14:16
  • Please see this new article 2017/02/10 10 most useless apps and games for Android. Most prominent, but specifically named in the list: Clean Master (along with quote-Booster apps, Anti-Virus apps, and Task Killers-unquote)
    – wbogacz
    Feb 12, 2017 at 2:10

6 Answers 6


I was facing a similar error with the Nexus 5. Safe mode and wiping the cache partition were not working for me. People also complaining about not be able to use the adb commands because the phone does not connect.

One option I read about was doing a factory reset. This is probably not the preferred option so I found another one. This worked for me although it seems a little unconventional.

  1. Download/install/open Nova Launcher
  2. Long press on screen
  3. Click on widgets
  4. Create a nova activity
  5. Scroll till you find setup wizard
  6. Look for setup wizard test activity
  7. Click on the icon you just created
  8. Run through setup

I also read that it is caused by almost full storage. Unlike in the description I did not get a message telling that the storage is full and the phone is going into a mode optimized for low available storage. After, the phone rebooted (I also can't confirm that the phone rebooted).

Source: http://forums.androidcentral.com/android-6-0-marshmallow/600742-nexus-5-marshmallow-home-button-not-working-many-more-problems-3.html#post5344015

Nova Launcher: https://play.google.com/store/apps/details?id=com.teslacoilsw.launcher

  • 1
    The Setup Wizard kept on hanging on a 'Just a sec' screen with intermittent crash messages. Setup wizard will crash if you disconnect the device from internet (wifi/data). If it is not crashing, remove sim cards and reboot the device. Setup wizard will start again. skip wifi settings. setup wizard will crash. try again and again (crashed 2 times for me). Setup wizard will be completed successfully. disq.us/p/1czhzx1 Oct 21, 2016 at 12:30
  • I had run out of storage and this error came up, same as the question described. Phone was in the same state even after clearing the storage and many reboots. I followed answer steps and phone is back to normal. Thank you. Nov 12, 2016 at 17:14
  • This worked great for me. Incase it helps future readers I had to set Nova Launcher as default launcher in Settings -> Home, then reboot the phone. Step 4 for me was called just "Activities", not "Nova activities"; there was a "Nova Action" which I tried first but was Nova specific. After choosing the language in the wizard my phone rebooted. The setup wizard asked me to add a Google account, whether to restore from another device, etc. I just skipped those steps and it correctly used the account that was originally configured on the phone, so I didn't lose any data or configuration. Mar 21, 2017 at 8:49
  • Perhaps a simpler solution is using Action Launcher to launch the activity. I had no luck with either of them (got a permission denied toast) but the device was rooted, so I downloaded terminal emulator and did: su and then am start -n com.google.android.setupwizard/.SetupWizardTestActivity, and obviously I granted SU permissions to Terminal. Hope it helps someone. What a stupid bug.
    – Zoltán
    Mar 22, 2017 at 20:28

AFAIK, there are 3 solutions for this issue (try it in below order): (2 & 3 need adb drivers or terminal app)

  1. Switch to guest and come back

Settings->Users->Guest (or)

Swipe down the notification bar and click on profile icon on the left top

  1. Start the initial setup and complete it or skip it

adb shell am start -n com.google.android.setupwizard/.SetupWizardActivity

--or if above doesn't work: --

adb shell am start -n com.google.android.setupwizard/.SetupWizardTestActivity

  1. Give below command to mark that setup is done

adb shell

$ settings --user 0 put secure user_setup_complete 1

  • Running "su" (you need root) and then "settings --user 0 put secure user_setup_complete 1" did the trick for me (mostly. I still can't open recents, but at least home button and most other stuff works). Thanks a lot.
    – ave
    Nov 24, 2016 at 17:25
  • Starting the initial setup via am start -n com.google.android.setupwizard/.SetupWizardTestActivity in adb shell indeed worked for me (Note that it is SetupWizardTestActivity, not as given in the answer).
    – user905686
    Jun 7, 2017 at 16:38
  • The wizard can be quit with the command am force-stop com.google.android.setupwizard but that might result in the problem being restored.
    – user905686
    Jun 7, 2017 at 16:46
  • Caution: Backup/sync everything before starting the setup wizard, because it might reset various things (e.g. the calendar storage (if syncing stopped before) or wifi passwords).
    – user905686
    Jun 8, 2017 at 9:48
  • 1
    .adb shell am start -n com.google.android.setupwizard/.SetupWizardTestActivity solves for instead of adb shell am start -n com.google.android.setupwizard/.SetupWizardActivity
    – androidXP
    Dec 9, 2019 at 15:51

apps like du saver / clean master /cm security is totally useless on Android phones they do nth much removes Android's garbage collection causing phone to again and again collect garbage....firstly uninstall all task killers and battery saving apps .

try cleaning cache partition and perform a factor reset if problem presets for factory resetting you need to follow this power button + volume(-) now select recovery mode wait until no command appears then first press power button then just click volume (+) you're good to go now


As Harshal Borade said, clean the cache partition. I had this issue with a new LG Phoenix 2. I wiped the cache and I was able to see recent apps. Google how to wipe the cache for your OS flavor.


I had exactly same problem on my Moto X Play. I was running out of space and I used to get alert all the time. 2 days back my phone restarted just like that and after that notif. drawer, home and recent apps buttons stopped working.

I could not even factory reset phone via Settings, that button was disabled. So, I searched through and got this video (https://www.youtube.com/watch?v=z0eaBzUUKqw) and got to know how you hard reset Moto X Play. I got into recovery mode and wiped data/factory reset. All back to normal now!

Hope it helps :D


After selecting a factory reset on Android 6.0.1, and unsuccessfully trying a lot of stuff for hours, I finally ended up with a solution that works for me.

In short:

  • Enable Debug mode on your phone. For me this was Settings/About and tap 7 (?) times on the Build number.
  • On your PC, install the Android Studio, to get the ADB program. After install you might find it in "C:\Users\your_username\AppData\Local\Android\sdk\platform-tools".
  • Open command prompt in that folder.
  • Run this command: adb shell wm overscan 0,0,0,15

The result is that you get a small area (15 pixels) on the bottom of your screen that is not in use, but your Home button(s) will again work. You can experiment with the value 15, maybe you need 25 or only 10. To reset to original settings, use the value 0.

Hope this helps someone.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .