Was stored as internal storage. The SD card when in the phone says "not inserted" and it's the card I've always used for it. The card shows up in another device and other cards show up in this device. I stupidly didn't have a backup so can't retrieve my images. I can't even access the SD card on my PC without formatting. Motorola told me that it's because the card is encrypted.

I think i'm going to end up formatting then trying data recovery software and hoping for the best. Because the card was treated as adopted (internal) storage I can't access any of my phone's contents via a USB wire either.

Please Help.

  • 1
    Data recovery software won't work because the card is encrypted. If your phone has lost the encryption key, or if the data is corrupted, then you have no real chance at recovery. – Matthew Read May 31 '16 at 6:08
  • @MatthewRead the card is saying "not inserted" when in the G3 however the same card registers on a PC and a different mobile device. Other cards also register with the G3. – Matthew Doherty May 31 '16 at 11:33
  • You'll probably have to re-partition and format the card with a PC in order for your original device to recognize it again. If you have a Linux PC you could try this before doing that: android.stackexchange.com/q/145443/1465 – Matthew Read May 31 '16 at 18:03

From what I have seen, it appears to be a known issue with the phone. I have had two SanDisk 32GB Class 10 MicroSD cards that have both had the same problem. However, I have seen forums that say the Class 6 cards work fine.

I have yet to test the new card, so I don't know if it fixes the problem, but I will update this post after testing it for a month or so.

  • I couldn't format in a PC because it was encrypted and I didn't have a key for it. Just doing without a card now, thank you. – Matthew Doherty Jul 20 '16 at 20:16

I can't take the time to read all the replies, but I can tell you that I fought this problem over and over until today I called Motorola support and learned that they will fix or repair these phones because it’s "a known issue". Why did it take me a year to find this information? I can only guess that they don't want it known. They will either a) have you return the phone for a free examination and fix (i.e. be without your phone for at least a week and probably much more, no guarantees) or b) send you a refurbished phone that they say they will guarantee will work for $24.95 + $75 + $11+ hold on your card until they get your old phone back (Really, is it legal to withhold tax on a credit card hold???). I chose option b so I could have a phone in the interim even though I am really upset with Motorola about charging me to fix my defective phone that they should have recalled and that they really should be refunding my lost money in multiple SD cards. So, forget all the nonsense people are saying about defective SD cards, clearing cache, reinserting cards, etc.etc.etc. and go to the source of the problem - the Moto 3G!


So on my wife's MOTOROLA as of this morning, I see 2 notifications: Lexar SD Card - Not inserted Lexar SD Card - Unsupported

I called Motorola support and learned that they will fix or repair these phones because it’s "a known issue"

I had turned it into internal storage 2 months back because it wouldn't work recording photos to SD card otherwise. Can Motorola recover the encrypted files for me? If not I will just cut my losses and get her a Samsung (I have mine and my daughter has one, no such problems with them)


I tried one way. Remove SDCard and try disabling Motorola Gallery and install any other Gallery app. Then try inserting the card. This worked for me when I am using it as external storage, not sure about formatted as internal storage.


I had the same problem on my Moto g3. I did not contact Motorola (or Lenovo) because I did not think they would talk to me as I have had this phone for more than 12 months. Anyway, I tried several fixes and none of them really worked. The phone would work for 24 hrs and then it would lose its SD card. So, here is what worked for me. I did a complete factory re-install. This is a little drastic but I felt it was my only option. I took note of installed apps I had installed. I had a good backup but I did lose some photos. The whole reinstall took me about 2.5 to 3 hours and my phone has now been working for 2 weeks with no issues yet. Just google "How to perform factory reset for moto g3"


Yes after formatting it as internal it won't work anywhere besides..phone itself... You can revert it from settings→ storage

  • 1
    The phone is saying that the card is not inserted. so I can't. – Matthew Doherty May 31 '16 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.