0

On my Sony Xperia Z1 Compact running CyanogenMod, I had the Google Play Services installed as an APK. At the time I must have thought that this was better than installing GApps - for being able to pick packages myself.

Since a recent update (of either Google play services or CyanogenMod) I get the error "unfortunately Google play services have stopped working".

Google play store also requires these services because it relies on these services. In the end I removed both the Services and the Store.

I have tried installing the a number of versions of the Services (from 7.3.xx to 8.3.xx) but they also report the same error message after a while.

Does the app need some sort of reset before it will work again? Each time an APK is uninstalled then its cache etc must be removed?

Or should I install a very specific version of the APK? my build is cm_amami_userdebug 5.1.1 LMY49J d8f66af955

EDIT:

For flashing GApps, I would choose Open GApps pico for Android 5.1 on ARM(32), does that sound right?

EDIT 2:

Flashing the GApps above worked. I would still like to know the answer to the first question - whether an APK could have solved it (and which)

  • 2
    why do you think GApps is not a better option? – Yogesh May 31 '16 at 9:14
  • Technically -- no idea, I would like to hear your thoughts! For ease of use and flexibility, APK looks the better choice. No need to boot to recovery, ability to remove the whole lot if it says "unfortunately ...". The end result should be the same? – alle_meije May 31 '16 at 12:29
  • I recently flashed my smartphone with cynogen mod 13 and GApps, and it was a lot easier and works perfectly. Finding a right version of play services and play store apk is really a painful task. – Yogesh May 31 '16 at 12:41
  • I've used GApps before and it works well. But until recently I had APK-installed versions of both GP services and store that also worked well --same end result. And removing GApps after flashing it when it doesn't work is impossible. So I was hoping to find an APK that works, or the reason (+cure) that GP services had stopped working. – alle_meije May 31 '16 at 13:12
1

The APKs for Google Play Services can be found on APK Mirror, along with explanations of the build numbers and how to determine the right build to install.

  • It says "download Play Services info or go to Settings -> Apps -> Google Play services, and look at the last 3 numbers in the parentheses" but option 1 does not work: play services info says: nothing installed. And then option 2 does not work either. In settings -> apps, there are no Google play services. – alle_meije May 31 '16 at 21:10
  • Tried the latest one just for luck. Still getting the "unfortunately ..." error and nothing running. – alle_meije May 31 '16 at 21:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.