10

So today Facebook Messenger declared a war against users of the mobile website. Of course we have been plagued for months with small header messages as well as overlays hiding all content and encouraging us to install Facebook Messenger.

But as from today, wherever I click in the messaging interface of Facebook's mobile website (and that includes the Message icon in the toolbar, clicking any conversation, clicking the Load more button, ...), each time it will open the Google Play Store application and send me to Facebook Messenger's application.

So I wonder if there is a way to prevent an application (in this case, Chrome) to open other applications (in this case, Google Play Store) via deep linking.
I don't believe that this is a bug that would be fixed any time soon so I am looking for a way to overcome this.

Installing any Facebook application is not an option for me.
I have searched for similar questions: answers suggested to clear Chrome's and/or Google Play Store's data, which I have tried but it did not solve the problem.

  • 5
    I can only think of using "desktop mode" in browser, because Facebook has been forcing their users to use their Messenger app on mobile (either web or FB app itself). – Andrew T. Jun 1 '16 at 7:02
  • Degraded UX, yeah! – Thibault D. Jun 1 '16 at 8:29
  • 1
    I have another solution. Download Firefox for Android and use m.facebook.com in Firefox. It is also a very good browser and does not open native apps, as Chrome does. – Ivan Kuckir Nov 25 '16 at 16:16
  • 1
    I investigated the issue and it seems that facebook detects if you use android and it redirects you to intent://threads/?vcuid=672877710&src=mtouch_diode&show_multiaccount=true. This evades the usual android configured rights "Open supported links": Ask every time. I don't know how this intent can be disabled. – raisercostin Jun 20 '17 at 18:58
  • 1
    So there's no doubt that this is annoying by design... – Thibault D. Jun 21 '17 at 6:02
3

"Request desktop site" works (for now)...

  • So you also noticed the problem, it's not only me? – Thibault D. Jun 1 '16 at 12:40
  • I noticed it too.... solution is not ideal but neither is installing fb messenger on my phone – GISKid Jun 3 '16 at 23:11
  • That is just awful. Even installing FB messenger does not help - instead opening Google Play, FB website opens the conversation in FB messenger :( – Ivan Kuckir Nov 25 '16 at 16:09
4

This worked for me: Navigate to

https://www.facebook.com/deactivate/

and delete your account, then don't ever visit the site again.

Facebook never opened the Play Store ever since, so I suppose this workaround is just fine.

  • Please add the essential steps from that Facebook link. – beeshyams Aug 22 '17 at 15:00
2

Depending on what version of android you are on you can clear the defaults of the play store so that it won't open up the play store when you click on a google play link from anywhere in android. The steps to do this vary by which version (skin and Android version) you phone/tablet is running. Generally you have to:

  1. Open Settings
  2. Applications
  3. Application Manager
  4. Find the play store and remove defaults for opening web links

This approach will however still bring up the play store on your web browser.

  • Seems like the right approach, +1. Although, I found the setting but it did not work on my Nexus 5 Android 6.0.1. Seems like a bug. – Thibault D. Feb 1 '17 at 7:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.