2

I am trying to root my Android device (the one in title) without success and I would really need it because of work reasons (in order to access app Caravel data and recover them in case the app does not start anymore).

I have followed many tutorial like the this and they all say the same thing. I have tried with many SuperSU BETA versions which I installed by flash from TWRP, as the tutorial say. The one which seems to work is 2.65; in fact, beta versions seem to block and freeze the device at boot. It just shows the logo and block. Instead, with 2.65 this does not happen. Then, superSU asks to be fully installed from play store but at the end I am not root. I checked with Root Browser and root checker and it seems that nothing worked.

What am I missing? Which is the correct procedure?

1

Try referring to this guide -

http://forum.xda-developers.com/2015-moto-g/general/guide-install-twrp-root-xposed-t3294588

It should work for your device.

1) Unlock your bootloader . for complete unlocking process go here.

https://m.youtube.com/watch?v=sw675i...ature=youtu.be

IT WILL RESET ALL YOUR DATA.

2) Turn on USB debugging on

3) Boot your device into bootloader mode

4) flash TWRP recovery v2.8.7 r5. http://forum.xda-developers.com/devd...1051#downloads

5) Boot into TWRP recovery

6) Flash supersu zip v2.62-3. http://download.chainfire.eu/751/Sup...1211162651.zip

7) After succsesfull flashing wipe cache/dalvik cache . reboot system. If it asks to install Root. DO NOT INSTALL ROOT AT THIS STAGE.

8) wait till Boot finishes.

9) If you want to install Xposed Boot into TWRP recovery.

10) Flash Xposed installer xposed-v79-sdk23-arm.zip. http://forum.xda-developers.com/show....php?t=3034811.

| improve this answer | |
  • This procedure is actually quite dated, although it still works. I will leave a more up to date answer that works on all Moto Marshmallow devices. – acejavelin Sep 24 '16 at 21:52
2

This guide covers ALL Moto G 2015 models (including the G Turbo) that can be bootloader unlocked, are running stock Marshmallow, and have TWRP available, it doesn't matter if it is the XT1540, XT1541, XT1543, etc., the method is identical. In fact, this method will work on all 2015 and 2016 series Moto phones running Marshmallow, including the Moto E, X, G3, G4, and Z.

Please read completely and make sure you understand each step and how to do it, if you don't get something search the thread or ask an open question.

tl;dr version for advanced users: Skip to "How to do it" section

I wrote this tutorial because there are still lots of failed root attempts using older "standard" methods that do not work on this device. I also do not like the "one click" root methods, because they can and do fail (KingoRoot will brick a Moto G3, regardless of what it's web page says), and when they do people have no idea how to fix it. The manual way is not difficult, and it teaches you how to work on, fix, and use your device on a level above that of the average smartphone user.

I will only cover the details of rooting, the prerequisites are covered elsewhere in detail and I will link to reliable sources for the information. Specifics of the prerequisites are outside of the scope of this tutorial, but are open for discussion in this thread.

Prerequisites:

1) Device must have an unlocked bootloader. See Moto - Unlocking the Bootloader for more info.
NOTE: Performing this prerequisite will give you all the tools (fastboot) and drivers needed to continue, and wipe your device, meaning erase all your information and programs. Make sure to backup any important data first. This step will also permanently void your warranty once an unlock code has been issued by Moto, it doesn't matter if you even use it, your warranty is done.

2) You need to have TWRP installed or one-time booted via fastboot. CWM and other recoveries will NOT work at this time. See TWRP for the Moto G 2015 or TWRP for Moto G Turbo.

3) You need a copy of the latest STABLE SuperSU ZIP from Chainfire's site on the internal storage or SD card of your device. As of this posting UPDATE-SuperSU-v2.76-20160630161323.zip is the current stable version. NOTE: Version 2.77 BETA is intended specifically for the Note 7 and should not be used for rooting Moto devices, in testing it doesn't brick or stop boot, it just doesn't show up or work. Stable version are even numbered.

4) Reboot and start TWRP recovery, the method you use to do this doesn't matter (boot or flash).

How to do it:

Now, the procedure is the same whether you are trying to root the first time, or you did it the old way just flashing SuperSU and are now not able to boot...

In TWRP, go to Advanced and open the Terminal, in the terminal type this EXACTLY as shown:

echo SYSTEMLESS=true>>/data/.supersu

Now press enter (there is no confirmation returned), then exit and press the Home key. Go to Install and select the SuperSU zip file you downloaded from Prerequisite #3 and swipe to flash it and reboot. No need to clear caches or anything else but you are welcome to if you wish. You can install SuperSU updates normally through the app going forward (as of this posting).

Why do I have to do this???

For whatever reason, the install script for SuperSU does not recognize that this device (like many others) requires a systemless root installation. By creating /data/.supersu in the TWRP recovery environment, the SuperSU install script parses the file and sees SYSTEMLESS=true and ignores what it auto-detects and forces a systemless root installation.

Hope this is helpful to someone!

As always, if this is the first time you have booted TWRP or attempted root... BACKUP IN TWRP FIRST!!! Once the system is modified, it cannot be undone (easily) and you will always have a known good starting place if the worst happens.

DISCLAIMER: I am not responsible for anything that happens... Your device, your responsibility, no matter what happens... Although all the information here has been tested and is known to work with no issues except where noted, things occasionally can and do go wrong and we cannot foresee every possible scenario or circumstance.

My original article

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.