8

After Android 6.0.1 update controlling the volume on my phone which is connected to a bluetooth device controls the volume on the bluetooth device. Before, when I changed the volume on my phone, the volume on the device still had his own volume control.

I understand, that for ease of use the merging happened - probably people disliked that they had to control two devices instead of one.

However, this means I lost a LOT of control over the fine tuning of the volume. This is a disadvantage for cases when you want to play through a bluetooth speaker a soft ambient in a low volume to fall asleep to. Now the lowest point of volume is high. Even though you can move the volume around in a non-discrete manner, you can hear, that only around 10-15 discrete volume values are used.

Is there no workaround, app, custom root modification or something I could do to switch back to two volumes instead of one?

1

Look for Fine Volume Control V2.0 in Google play. I installed it based on earlier comments and cannot believe how happy I am with it!

  • Yeah, I used this and it helped me, but then I changed my phone and the problem disappeared. Don't know why I forgot to mention the app here. – Ev0oD Mar 7 '17 at 14:14
  • 1
    App is not free. – Felipe G. Nievinski Jan 15 '18 at 2:51
15

Goto Developer Options, activate the "Disable Absolute Volume" toggle (see screenshot). Disconnect and reconnect your Bluetooth connection. Problem solved.

NOTE: This was done on Android 7.0. You can try on your own OS version.

IMG:

  • 2
    To enable developer mode, go to Settings-> About Phone and tap the Build Number 7 times. forum.xda-developers.com/xperia-l/general/… – Bar Oct 16 '17 at 14:22
  • 2
    It also works on androud 8.1!! Also thanks, it solved my issue. – Matt Jan 8 at 14:21
  • I had to disconnect and reconnect my headset, but then it worked perfectly! – chrylis -on strike- Jun 28 at 18:58
0

enter image description here

Android 9 on OnePlus allows this through Sound > Earphone mode > Bluetooth absolute volume.

protected by Community Aug 29 at 9:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.