7

In settings of Android phone, there is a search button in the Action Bar and it cannot give me what I want to search. I find it works sometimes but 90% it doesn't. The 2nd image shows the very irrelevant results.

For example, I enter battery to search for battery settings, it gives me nothing.

My question is: how to fix it?


search settings

And result when enter ba:

enter image description here

8
  • Is this Android N? It works for me on a Nexus 6P with Android N: imgur.com/oEA8ZIZ
    – Thomas Vos
    Commented Jun 3, 2016 at 6:04
  • I have one M and one N with the same symptom. Commented Jun 3, 2016 at 6:07
  • It works on Moto X play stock 6.0.1. Two things I noticed 1. Typing 'Battery' letter by letter reveals all battery related things 2. If your keyboard is prompting you battery and you select it make sure there is no space after the word (if there is a space it shows nothing, deleting space by back arrow reveals). In both cases, I see Battery, Battery saver, Battery optimisation, Adaptive brightness and battery level as search results
    – beeshyams
    Commented Jun 9, 2016 at 6:11
  • It searches only for subgroups in my N. That bug I know. Commented Jun 11, 2016 at 17:01
  • @TungD.Nguyen What ROM/Device? From reading the answers and comments, this sure sounds like a ROM code problem and should be handled by the ROM developer(s).
    – acejavelin
    Commented Jun 11, 2016 at 18:46

4 Answers 4

0
+50

May be the system bug. Try clearing cache and dalvik cache. If problem presist try factory data reset. If still presist, then its a Rom bug. If it is, then wait for the update for fix.

2
  • 1
    I tried it before: reset to factory/re-install rom/clear cache... The same results: enter B it can give bluetooth but no battery in the result section Commented Jun 9, 2016 at 2:25
  • Yes! After the update to Beta, the search function works again Commented Jun 16, 2016 at 2:31
5

I cleared data and cache from settings app and it's worked for me. Not factory reset and clear cache from recovery. I went into settings>apps>allaps,settings>storage and clear cache and data

2

What worked for me on Android 9 was: Find system app "Settings Suggestions", open app info, press force stop, press storage and hit clear cache and clear storage buttons.

5
  • Settings Suggestions is a system app: in order to show it in the All Apps list you need to tap on the more options icon (three vertical dots, aka kebab menu) in the top right corner of the screen and select "Show system". Commented Mar 15, 2020 at 8:13
  • Thanks! After forcing stop worked. But
    – mcwong
    Commented Aug 17, 2022 at 16:10
  • Thanks. Forcing stop works! But not sure if the problem will return?
    – mcwong
    Commented Aug 17, 2022 at 16:11
  • Problem returned next day! Now doesn't work anymore
    – mcwong
    Commented Aug 18, 2022 at 17:16
  • Only works temporary, the issue returned the next day and forcing stop no longer work
    – mcwong
    Commented Aug 19, 2022 at 4:22
0

It sounds like search may be disabled for you.

Go to your Settings > Apps > swipe to the “ALL” tab > select “Google Search” > press “Enable”.

1
  • Sorry, it does not work. All apps are enabled in this directory! Commented Jun 3, 2016 at 0:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .