Just bought a cheap MID 7" Android 2.2 tablet. Tried opening the icon on the desktop that says Install Apps and all I got was a page with a heading of AppInstaller and then /mnt/sdcard. When I tried to put in the URL for the Android Market, it didn't work. When I used the browser to go to the Market page and install an app, I get the message that there's no Android devices associated with this device. Any ideas?

  • 2
    Does the tablet actually have the Android Market installed on it? It sounds like it's not a Google-approved device. Oct 17, 2011 at 16:37
  • So, I downloaded the Android Market, but it gives me an error (too quickly to read) when I try to open it. The app. installer icon shows the market info, but when I click on that it just asks if I want to uninstall. I tried uninstalling the "app installer" in case having two app. installers is the problem, but it won't let me. Any last ditch advice before I sent this back to China?
    – Shelly
    Oct 28, 2011 at 20:18

2 Answers 2


This Android Police post has a link to the current Market version (note it's the standard Market, not the Tablet version which only works on Honeycomb). If you download it from your device you should be able to use your AppInstaller to install it from /mnt/sdcard/download/.


As an alternative, you can get apps from 1Mobile Market instead:

  1. Download the apk from CNET to your PC.
  2. When it asks you if you want to open or save, save it, and remember where it's saved.
  3. Then connect your tablet to your PC/laptop via USB
  4. Go to where you have saved the file and right click it, then send to your Android.

On your android you will find a new icon called '1MobileMarket'. Use this to download apps instead of Google Play.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .