Device and settings:

enter image description here

Goal: I wanted to take adb backup on Mint Linux (17.3) of my apps (with data if possible) and internal SD using this Full Backup of non-rooted devices as reference


  1. When I key this in terminal

    adb backup -apk -shared -all -nosystem -f moto.ab

    I get the prompt "Now unlock your device and confirm the backup operation " in the terminal but nothing happens on the device- I do not see any panel to accept or enter desk top pass word as in pic below (it's the same if I try -system instead of -nosystem)

enter image description here

  1. The terminal reverts to prompt for next command in a few seconds ( A 0 Kb file is created on the laptop)


Am I doing something wrong or Marshmallow require some extras to take a backup as desired?

Moto devices are said to be "pure Android" so I expect this problem to be prevalent on Nexus devices running latest OS

Edit: Things tried with varying sucesss

  1. Nexus 5 Marshmellow ADB backup problems. Going by this post

(....) it appears that adb backup isn’t recognizing the -apk, -nosystem, and -noshared switches. Any idea why? From the command line, if i remove those switch the backup runs

adb backup -all -f moto.ab 

works in the sense that I get the option on panel to enter password back up (problem 1 above overcome) but the file size (105 Mb) shows all apps are not backed up (In comparison using ES File explorer, the size is 2 GB)

  1. I had read somewhere on this site that Helium app is based on adb. Helium Wiki says

Helium is NOT available to Motorola devices. This is because Motorola phones have a bug that break Android's backup mechanism. Until this is fixed by Motorola, Helium will not work on those Androids (....) Update: Helium is working on the Motorola Droid Turbo.

That obviously explains why it doesn't work on my device was the logical conclusion. This called for experimenting, so I downloaded Chrome extension of Helium and activated it (it needed a little workaround explained here )

I selected all apps under Helium and it backed up (less some apps shown as "non backable") with a size of 110 Mb (similar to above experiment)

So, apparently, my device Moto X play is not the problem !

  1. Tried solution here ADB backup creates 0-byte file; prompts for current backup password even though I never set one; “Failed to set password” for Desktop backup password recommending escaping spaces between arguments

adb backup -apk\ -shared\ -all\ -nosystem -f moto.ab and got a 0 Kb backup file

  • 1
    In both of the screenshots you posted, ADB is not connected. Did you turn on USB debugging in the developer options? (It's completely separate from the two dialogs you posted.)
    – Dan Hulme
    Jun 8, 2016 at 10:06
  • Note: I guess ADB can only back up apps that have the allowBackup:true set in the AndroidManifest.xml, whereas ES File Explorer can probably back up any APK it finds via the package manager, regardless of the above attribute. Jun 8, 2016 at 13:15
  • Following up, we should not ignore the new fullBackupContentattribute for theapplication tag for AndroidManifest.xml introduced in Android 6.0, and how that might affect the behaviour of adb backup Jun 8, 2016 at 13:18
  • As much as I hate to say this, my Nexus 9 running 6.0.1 does not have such a problem with the mentioned command. It's rooted, however, and does not have a desktop backup password set up, and the device encryption is as default. There might a subtle thing here: You say your device is not encrypted, but in the pic of some KitKat device there, the desktop backup password is the device encryption password. Could you shed some light on the issue? Jun 8, 2016 at 13:21
  • Also, what's your platform-tools version? I tried with the latest stable and the latest preview versions, as both work OK. I guess the take home message is: Moto devices don't run pure Android. Jun 8, 2016 at 13:24

4 Answers 4


Same problem here - this is how I fixed it on my side. Preparations:
- Samsung Galaxy S5 on Android 6.0.1 (not rooted)
- adb v. 1.0.32 running under Windows 10 command line
- password set on the S5

I succeeded when using quotes for all switches:
adb backup "-apk -noshared -all -nosystem"
-> will prompt for the password and produce a backup.ab

To backup single apk using a custom file name:
adb backup -f all_apk_obb.ab "-apk -obb com.estrongs.android.pop"

Seems that the switch handling of adb is a bit weird in the latest releases. I did that before and my old scripts are not working anymore.

  • Windows 10 and adb.exe version 1.0.31 works with extra parameters, if you put them in double quotes: adb backup "-all -shared -system -apk" -f "e:\backup\samsung.ab" also - notice, that "-f ..." should be outside. This worked for me. Sep 25, 2016 at 8:37

It´s a known issue and it's still not solved:


  • +1 for inputs that may be useful for other users. In my log I don't see this error and as mentioned in the question OS is 6.0.1
    – beeshyams
    Oct 10, 2016 at 12:19

I don't have this cell phone, but you could try this:

On the "config -> security" is there an option "authorized agents" or something like that? And in that option, is there the option of a Backup agent?

Turn it on and test "adb backup" again.


  • No i dont have it
    – beeshyams
    Aug 12, 2016 at 1:49

If you are using widnows, try

adb backup "-apk -shared -all -nosystem" -f "moto.ab"

instead of

adb backup -apk -shared -all -nosystem -f moto.ab.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .