My Sony Xperia Z3 Compact was recently updated to android version 6.0.1 ("Marshmallow"?) using the Sony update tool, from version 5. Phone isn't rooted, no custom stuff, only ever updated via Sony updates, etc. UK based.

Before the update, if I connected it by USB to my (Windows 8.1) laptop, the following would happen:

  • The SD card would appear on the PC as if it was USB pen drive
  • The phone charges and I'd get a message on the phone asking if I wanted to "install" Sony software on the PC (every time, even if I'd agreed to "install" it last time)
  • On saying Yes, the SD card would disappear and would be replaced by a Sony icon that let me access both the internal memory and SD card like they were two directories on a USB pen drive

After the update, the following happens. Basically I can never access the SD card or internal memory on the PC no matter what I choose:

  • The PC doesn't react, nothing appears on the PC
  • The phone charges and a menu pops up giving me four choices:

Use USB for

  • Charging only Just charge this device
  • Transfer files (MTP) Transfer files to Windows or Mac (MTP)
  • Mass storage mode (MSC) Transfer data between phone SD card and a computer
  • MIDI Use device for musical instrument apps (MIDI input)
  • Neither "Transfer files (MTP)" nor "Mass storage mode (MSC)" do anything when selected. If I select either of these, the menu disappears, but nothing else happens - nothing appears on the PC (no drives or anything), nothing displays on the phone.

It behaves exactly the same as if I'd selected "Charging only".

How can I investigate why this isn't working? What do I need to do to make file transfer on 6.0.1 with a PC by USB work like it used to? Is there some special Sony-only thing I need to do?

I've looked at Marshmallow USB connection type. Various answers there suggest things like:

Swipe down the notifications window with the device plugged into the computer, there should be a persistent notification for USB Mode

...there actually isn't any such persistant notification at all for me, no matter which mode I choose. Also, unlike the description of that question:

Windows detects it, installs the drivers automatically and shows the device in My Computer...

...none of that happens for me. The computer is completely unaware of the phone, although the phone does react to being connected to the computer.

4 Answers 4


This is bizarre. I connected the phone via a different USB socket on the computer (same cable), and this time it worked fine, in fact better than before:

  • The Sony icon appeared without needing to "install" anything, and accesses both internal and SD memory like before
  • The "Install software" Sony message pops up on the phone like before now
  • The missing persistent notification on the phone appears:

    USB for file transfer Touch for more options

I wasn't aware of the computer having different types of USB socket, but it seems like maybe there are some types of USB socket that an Android 6 phone will think work but actually don't?

I thought it might maybe have been a driver install thing, but the "bad" USB socket still doesn't work even after successfully using the connection to the "good" socket.

To add to the mystery, I have actually used this "bad" USB socket on this computer with this phone before, mere days before the Android update. Somehow the USB socket appears to compatible with Android 5 but not Android 6?

The "bad" USB socket also has no problem working with USB pen drives.

If anyone happens to know how I can find out what the technical difference between the two identical-looking USB sockets on my PC is, please comment!


if it helps: I have exactly the same problem. I do not think it has anything to do with the actual USB socket, even if my impression also was that just one USB 3.0 socket made the phone stop to ask about the USB connection all the time. My theory for the moment is that when I let the phone keep hangig for a long time, it stops asking about mode and all the beeps stops. So I suspect that it has to do with the current supply detection and how little is left in the battery. Perhaps one socket on the PC can deliver slightly higer current and that could make it look like this port only support the phone. Stamnia mode or not has no impact. In my PC, I have removed all Sony software due to full HD. It did not really add any value to me, but perhaps this new things requires the Sony SW on the computer? Never the less...a flaw that appeared after an update as you say


If you want to transfer files wirelessly, or if any of the above answers are too confusing or difficult to do, just search "Asus share link" in Google and install it on your PC. Install the same app on your phone through the google play store. Then just follow the directions in app. This will take longer to transfer files than via USB.


When you change to another USB socket on Windows, quite often the PC will re-scan the hardware and re-install drivers with different "instantiations". I have used this trick in the past to allocate more COM ports on a USB-Serial adapter driver, for instance.

You may have found that deleting all the Sony-related drivers off the PC, and using the same socket, would have had the same effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .