0

My device (maybe) doesn't support Multiple Users. I have a rooted device with Xposed Framework installed.

I installed an app from the Play Store (I think it's named as "Multi Users", or other similar to that ...), grant that app a root access, and enable that feature. Then, I go to "Settings", and the "Users" Option was there. I add another account, and when it opened a Dialog Box telling me to setup that account now, I rebooted my phone because it was too slow ...

Now, when the phone had finished rebooting, my apps are gone (I mean, when I try to open them, they keep telling me Application not installed); as well as my third party launchers, lockers, clocks, etc.

Previously, I had done this before (but with a different app), and it gives me options on the Lock Screen to switch to Users. But, this app doesn't have that option.

Also, the "Users" options is now hidden / not displayed on the Settings.

I also downloaded the ".apk" file of Root Browser (I already downloaded ES File Explorer, but cannot launch it due to that "Application not installed"), but it won't let me install either.

Will fix this? - I hope so ...

My device is running Samsung Galaxy Core Prime - Android 4.4 (Kitkat) with Root and Xposed Framework installed.

Please HELP!

0

I can think of two possible things:

  • Hold the power button. Some phone has "Switch User" option on power menu.
  • Hold the "Power Off" option and select "Reboot to safe mode". May be you can figure out something from safe mode.
  • Nope, this doesn't help me. There is no "Switch User" option on the Power Menu. And, I still cannot switch users when I'm on to Safe Mode. Anyways, thank you for providing answers! 😊 – Lloyd Dominic Jun 7 '16 at 10:27
  • @LloydDominic but while in safe-mode you could remove that app, which hopefully lets you access your other apps again. – Izzy Jun 7 '16 at 12:04
  • By the way, it was hard on recognizing the app that did that thing, because the Application Manager (on Settings) displays the Package Name of the App, not the name of the App itself. – Lloyd Dominic Jun 7 '16 at 12:50
  • I uninstalled the app, and it still doesn't let me change accounts, etc. The app just activates the feature, so when I uninstall the app, nothing happens. Right now, I'm hoping an ADB solution. – Lloyd Dominic Jun 7 '16 at 13:02
0

I'm so lucky, I just tested it, and it worked!

So, the USER_ID for the Primary User Account is 0.


Using your favorite Root - Only File Manager, navigate to /data/system/users, delete the other User Accounts ...

For example, the "unknown" USER_ID is 10, delete these files / folders:

  • Folder named 10.
  • 10.xml
  • 10.xml.mbak
  • And, edit the userlist.xml removing these line:

    • <user id="10" />
  • And if you want, you can also delete that line from userlist.xml.mbak.

    • (I think nothing will happen if you delete that file, because I think this is only a backup)

If your stock File Manager doesn't let you access the root drive / system files, follow these steps:

  • You may have to download an .apk of the Root File Manager that you want to use, using another device.
  • Push the downloaded .apk file to /system/app on your Android Device using .
  • Reboot the device.
  • The .apk should now be installed automatically, and you are ready to do the steps above.

Bonus tip: You should also delete other files / folders, if you want to only use the Primary Account.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.