0

Two weeks ago I tried to root my android phone using Kingo root app on android but somehow it went wrong and it stopped but it copied the Superuser.apk to system/app and now I want to delete that file using adb. But when I type rm superuser.apk It gives the following error : rm failed for superuser.apk, Read-only file system and when I use to mount the file system with read write access with this command : mount -o remount,rw /system I get this error :mount : Readonly file system. I dont know how to delete Superuser.apk, Please help me, thanks

  • Are you superuser? You know you can only use mount when you have root permission? – GiantTree Jun 7 '16 at 13:42
  • Yes, my phone isn't rooted and it has got superuser.apk! :( – Ehsan Jun 7 '16 at 13:44
  • @GiantTree, please help what should I do??? – Ehsan Jun 7 '16 at 13:50
  • You need to properly root and remove that file or flash a stock ROM to reset the /system partition. – GiantTree Jun 7 '16 at 14:01
  • 1
    If you want to properly root your phone, check xda-developers. Search for your exact phone model and follow the simple step-by-step guides to root your phone (might require you to unlock the bootloader, but I don't have a Huawei to confirm). – GiantTree Jun 7 '16 at 14:10
0

I think your phone has been rooted and the just thing you need to do to remove that Superuser.apk is

  1. Open adb shell.
  2. Type su(It will give you superuser access).
  3. Then change the file permission (mount the system folder to read and write) and just simply remove that app.
  • No bro you just missed it, it isn't root, the rooting process failed at the middle without and recovering and I'm finally giving up root - :( – Ehsan Jun 16 '16 at 10:11
  • @Halo_HeroOfReach As far as I know, the app like Superuser or Busybox are copied to the phone only after the phone has been rooted. Have you tried typing su in adb shell? – Aman Jun 17 '16 at 0:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.