0

I want to move some of my apps from my internal memory to my extsdcard. I followed this to do so(I'm not using Marsh Mellow so skip the first part of the guide). When I installed Link2SD and rebooted my device it flashed an error saying:

"Mount Script Error. [4]: can't create /system/etc/init.d/11link2sd: Not a directory"

I searched for this error and landed on this page. The solutions provided here do not seem to work for me and I wonder if it'd be dangerous to manually delete the file "init.d" and create the directory that Link2SD has been trying to create. But before I do so I want to know what exactly is this file for and would it be safe to delete it?

Bonus Question: Even if I delete it, would it be created again after I reboot my device?

  • 1
    The init.d is not a file, but a directory. What Link2SD is trying to do, is to write a script in that folder, since any script that's stored in said location will be automatically executed at boot (if your kernel supports the feature, that is). – Death Mask Salesman Jun 7 '16 at 20:20
  • @DeathMaskSalesman : But I did see the file myself. Anyway I solved the problem. I'll write an answer to it. – 7_R3X Jun 8 '16 at 4:48
0

Link2SD couldn't create folder "init.d" in /system/etc because there existed a file with the same name. I deleted the file manually by browsing to the location, launched Link2SD and selected the "Recreate mount script" option. It worked for me. I feared that something might go wrong with the device when I'd reboot it but everything is fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.