6

I use Android Marshmallow in Nexus 5x. I have an automatic rule for nights where it goes to Do Not Disturb with priority only as set. It works as expected and silences when someone calls me over cell network, but if someone calls in Viber, (an app like WhatsApp) the ring comes in with all it sounds, but I expect it to be silent as well. What I am doing wrong?

5
  • Try changing your priority settings in Settings -> Sound -> Do Not Disturb rules -> Priority only allows. Try turning off message or call notifications?
    – owlswipe
    Commented Mar 2, 2017 at 23:18
  • 1
    Also try going to Settings -> Apps -> Viber and turning off "Override Do Not Disturb". This will most likely solve your issue.
    – owlswipe
    Commented Mar 2, 2017 at 23:20
  • Let me know if those help or not with a comment @Owlswipe.
    – owlswipe
    Commented Mar 2, 2017 at 23:20
  • In case, recommendations of owlswipe don't help and you are looking for an automation solution, let me know
    – beeshyams
    Commented Mar 3, 2017 at 8:04
  • I've posted a detailed answer of how to fix this issue. Let me know with a comment below my answer whether or not it helps, otherwise I'd be happy to assist more!
    – owlswipe
    Commented Mar 6, 2017 at 1:20

1 Answer 1

4
+50

There are two possibilities for what's causing Viber calls to ring during Do Not Disturb Priority Mode. Here's how to fix both possible issues:

Priority Only Rules

It could be the fault of your priority only rules. Go to Settings -> Sound -> Do Not Disturb -> Priority Only Allows and set both Calls and Messages to none. This will stop calls and texts from ringing your phone while you're in priority mode (from your stock phone/messages apps and potentially also from Viber).

Override Do Not Disturb

The other possibility is that you're overriding Do Not Disturb restrictions for Viber and letting it sound during priority mode. To turn this off and block Viber calls from sounding during priority mode DND, go to Settings -> Apps -> Viber -> Notifications and turn off Override Do Not Disturb.


tl;dr: Change your priority mode rules or block Viber from overriding priority mode Do Not Disturb to fix your issue.

2
  • @Norfeldt Let me know if this helps or not!
    – owlswipe
    Commented Mar 6, 2017 at 1:20
  • It did! Thank you very much! I can now sleep undisturbed...
    – Norfeldt
    Commented Mar 10, 2017 at 15:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .