I use oneplus one with CM13. There is a privacy guard that allows to block any permission for any app/service. I applied this feature to Google Play Service. Now it asks me allow some permission and hangs right after device booted so I can't even unlock the screen for letting the service do what it asks. I can boot to recovery mode and do a factory reset but I would like to keep some files/fotos from my android. The device is on the stock recovery and firmware with OTA update. Not rooted. No USB debugging mode is on. Is it possible to bring the system back to the normal state or at least to pull the files from it?


2 Answers 2


This is a known issue when blocking Google Play Services using Privacy Guard on CM13. However there is a workaround if the device has a custom recovery like TWRP installed.

  1. Boot into recovery
  2. Open File Manager
  3. Navigate to /data/system
  4. Delete the file named appops.xml
  5. Reboot.

Since you've not rooted/installed custom firmware, the only option is a factory reset from recovery. You'll lose all apps, but data stored on the device storage will be safe.

  • This needs to be the accepted answer thank you so much. Still works on CM14.1 (with a v20).
    – DrJPepper
    Commented Apr 7, 2017 at 0:05

I did the exact same thing, and indeed the phone crashes just when I am about to enter my passcode. Luckily, a simple boot into safe mode worked just fine, and after changing the location permission from Always askto Allowed, it worked again.

How to boot your Oneplus One into safe mode:

When the phone is off, press the power button until the phone boots up, then immediately start holding both volume buttons until android is fully booted.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .