0

I have a Samsung Galaxy Tab p3100 and i can't flash anything. All I have is a Stock CyanogenMod recovery and i can't even go through odin and install a new cwm/twrp. I don't know why but it says USB device is not recognized :(

I've tried to uninstall the usb thing in device manager but no luck. My only chance is flash a rom or a SIGNED cwm/twrp (i guess i'm running out of options) for my device but i can't find any signed zip file to be flashed on cyanogenmod recovery please help.

  • and i did buy a new usb cable but still not working :( help pls im dying.. – CryGuy Jun 12 '16 at 10:26
1

You can install TWRP with root access without the need of a PC.

  1. Download the latest image for your device here.
  2. Your phone needs to be turned on.
  3. Copy the recovery IMG to the root of your sdcard and rename it to twrp.img.
  4. Open a terminal application and execute this command: su -c "dd if=/sdcard/twrp.img of=/dev/block/mmcblk0p6"
  5. The custom TWRP recovery is now installed.

Note: Do not use this guide for any other devices, it will be bricked.


The reason your device isn't recognised on your PC is probably because you have Windows 8/8.1/10 installed. The drivers (ADB) for Android phones do not work correctly yet. There are some workarounds on the internet.

  • Hmm, about that .. I can't reboot my device up and open a terminal application because that's my problem too i mean i formatted system thru cm recovery i did that because I'm stuck at the logo, and i am using windows 7 os, i did try to plug my device on other pc from my friend but no luck. – CryGuy Jun 12 '16 at 11:28
  • and also IDK why that cm recovery just appeared i didn't touch anything on dev settings when my tab is working before.. – CryGuy Jun 12 '16 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.