I have read this and this question and I want to ask for some elaboration.

I'm considering buying an x86 phone. I have some questions regarding compatibility issues.

  1. I know that the majority of normal (non-root) apps will work without issue on x86, but I understand that there are exceptions. Apparently some apps use native ARM functions. How common is this? What are some examples of popular apps that won't run on x86? Can I get an idea of how widespread this problem will be?

  2. Is it true that root apps are less likely to run than normal ones? How widespread is incompatibility with x86 in root apps?

  3. I know that Xposed Framework can work on x86, but what about the modules? Are many of them incompatible with x86? If yes, how common is it?

  • Have you checked in the forums for various x86 devices, such as the Zenfone 2? I know on XDA they maintain a thread on app compatibility, in general most things work. "Root" privelage apps are about the same, most work fine, there are a handful that do not. My experience with Xposed on x86 devices is limited, but the one device we tried it on didn't fair well, out of about 4 or 5 modules we tried it was a 50/50 split. TBH, if you are getting into Xposed, why not just use a custom ROM?
    – acejavelin
    Commented Jul 6, 2016 at 17:48
  • @acejavelin Yeah, see my comment on the accepted answer and the answer I myself just made. My experience is pretty much the same as what you said in this comment. Regarding custom ROM, I actually think the stock firmware is pretty decent. I like the UI. It has native Greenify-like functionality. A bit much bloatware, maybe, but that's easy to remove.
    – Fiksdal
    Commented Jul 6, 2016 at 17:56

2 Answers 2

  1. It's mostly games that might be incompatible with x86. Typically, apps have no reason to use the NDK unless they has special performance or graphics requirements, and their libraries might only be built for ARM.

  2. I don't believe that apps using root are typically incompatible, it's rooting apps — since they often rely on platform-specific binaries/exploits. Root apps are not inherently different in how they are coded than others apart from requesting elevated privileges via su.

  3. Unfortunately I am not familiar with Xposed support for x86, but I believe the answer should be similar to #2. Xposed mostly functions by injecting itself into Android's platform framework, which is Java rather than native libraries. I would advise you to be careful with backups and making sure your device is relatively easy to flash if you need to restore everything to stock.

  • 1
    FWIW, the guys at XDA have done a lot of testing and reported on which Xposed modules work. It looks like most modules work.
    – Fiksdal
    Commented Jun 13, 2016 at 11:22

I did buy it. So far, all apps * (root or not) and six out of eight Xposed modules I have tried have worked. This is a somewhat small sample, because I haven't tested any apps I don't use myself. These are just the apps I personally use:

* = Update: Pokémon Go does not work on x86 at the moment.

Some working root apps

  • Adaway
  • BusyBox installer by Meefik
  • f.lux
  • Linux Deploy
  • OS Monitor
  • Root Browser
  • Root Checker

Some working Xposed Modules

  • Gesture Navigation
  • Network Speed Indicator
  • NoSafeVolumeWarning
  • YouTube AdAway
  • YouTube Background Playback
  • YoutubeSwipeToSeek

Some NON-working Xposed Modules

(I don't know if this has anything to do with x86, may also be Lollipop incompatibility? No idea.)

  • Notification Mod
  • Rootcloak

The guys at XDA have done much more extensive testing in this thread.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .