I purchased an app from the Android Marketplace and the download will not start. It is stuck at "Starting Download..." and none of the suggestions on the support site worked. I can download other apps just not the one I purchased. My credit card was charged for this app -- it was charged twice in fact (I think that could be the issue maybe?)

I emailed Google support, and they responded with the following:

  • Cancel and restart the download(s)
  • Reboot your device
  • Sign in and out of Google Talk repeatedly to restore connection to our servers:

    1. Go to your device’s app launcher, and press the Talk app
    2. If you’re already signed into Talk, press Menu, and then touch Sign out
    3. Launch Talk again to sign in (if you are unable to sign in, please let me know)
  • Clear the Market cache (Menu > Settings > Applications > Manage applications > All > Market > Clear cache)

  • Clear the Download Manager cache and data (Menu > Settings > Applications > Manage applications > All > Download manager > Clear cache and Clear data)

  • Ensure there is at least 20MB of free space on your device

  • Try your download(s) using both WiFi and network (3G/4G) connections

  • Try to initiate your download from the Web (market.android.com) instead of the device

  • Ensure firewalls are not blocking access to ports required for Android Market (TCP and UDP 5228)

  • Confirm that there is strong connectivity on your device, and contact your mobile service provider if you aren't connected

  • Uninstall Market updates by visiting:

    Settings > Applications > Manage Applications, selecting "Market" under the "All" tab or filter and touching "Uninstall updates"

I tried all of those things and responded that none of them worked. Their second response told me to perform a factory reset!

Before I do something that drastic, what else can I try?

UPDATE: I went ahead and did a factory reset and I still cannot download this app... any other suggestions?

  • Have you tried long-pressing on the download notification and cancelling? I've had a few app installs that seemed to get "stuck".
    – ale
    Commented Oct 24, 2011 at 19:45
  • @Al: Sadly, yes I did... no luck!
    – Josh
    Commented Oct 24, 2011 at 19:49

2 Answers 2


I am not sure why this happened... I suspect it was due to my open issue with the Android Market team... however I suddenly got an email that my order for this app had been canceled:


Your order has been canceled and you have not been charged.

Reason: Other (describe below)

Comments: We could not complete your order in a timely fashion. Your order has been automatically canceled. Please retry your purchase.

I was then able to purchase and pay for the app again, and this time, it downloaded!

  • That's awesome! I can only imagine that the transaction got hung up somehow and they finally cancelled it. (If memory serves from my e-commerce days, authorizations automatically expire if they aren't used by an actual sale within some days. But my memory is murky.)
    – ale
    Commented Oct 26, 2011 at 20:28
  • I was thinking that too @AlEverett... either way I can SSH/SFTP into my phone now, so much easier for grabbing pictures off / managing media!
    – Josh
    Commented Oct 26, 2011 at 20:29

I had a similar issue once. It occurred immediately after I got a refund for another app that didn't work (I bought the one that got "stuck" to replace the refunded one). I was lucky in that after an hour or so the download started on its own and everything was fine.

So that's one option. Another is to contact the seller of the app, explain what happened, and ask for a cancellation/refund. Hopefully it fixes the issue, but if not you'll at least be able to get your money back.

  • 1
    Thanks... it's the next day and the app still won't download. I may contact the seller of the app and ask him to cancel the order. As I explained to Google I do want this app and I'm happy to pay for it... maybe the developer will cancel my order knowing I'll just reorder again. I just want the download problem fixed, not my money back! :-)
    – Josh
    Commented Oct 21, 2011 at 11:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .