1

Memory on my phone was low, so I went to the apps and deinstalled some. Among these apps was “Google—A handy search for underway”, and since I also have Firefox, I decided that I don’t need the Google search, so I deinstalled it. And it worked, the app got deinstalled. But it was not only a search app, it was the whole home screen app, so my home screen didn’t show up anymore, and I could only switch the phone off.

I booted it again, and now it shows the “Android is starting”, subtitle “Apps are starting”. This takes about 30 minutes now.

I did not root my phone or do anything else, and still I could deinstall the Google app.

How can I get my phone working again?

1
  • re flash your ROM using software like PC companion(in SONY) of your phone.
    – Kaushal28
    Jun 13, 2016 at 13:17

2 Answers 2

1

I ran into this issue on an old RCA Viking tablet. It seems that the Google App is used as some kind of launcher, as I could hear it actually "finish" booting (it's deceiving because there's also a Google Now launcher app, which I left alone). If you still have internet access connected, you can use a different device and reinstall the Google App from the Play Store as long as the bunk device is still listed there.

This should preserve your data, but your home screen will be reset.

1
  • A hard reset is not a real solution, and not every device allows you to flash ROMs. My solution is much simpler, and the only one that preserves user data, and I've yet to find it anywhere else online. I also already mentioned that the user needs access to the Play Store and that the device needs to be listed, whether from a browser or another device with access to the app doesn't matter.
    – Kovaelin
    Feb 27 at 21:14
0

The actual solution was quite easy:

  1. Power down the phone by long pressing the Off button
  2. Boot the phone into fastboot mode by pressing On and Volume-Down
  3. Select “Factory Defaults”
  4. See Android booting again, having preserved all of the installed apps; only the Home screen had been emptied—oh, sure, I had deinstalled the Home screen app. That’s how the whole story began.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .