1

I have a stock android. When I was running Android Lollipop, I had an option to type a word, long press on it, and an option would pop up above the keyboard to add that word to the dictionary.

Now I am running Marshmallow 6.0.1, and I can't seem to get that option, when I do a long press on a word, I get CUT, COPY, SHARE and triple dots, On clicking triple-dots I get back arrow and TRANSLATE.

How do I add word to dictionary from keyboard? I do not want the long cut Settings-> Language & Input ->Personal dictionary->For all languages -> +

  • 2
    It's there on my Nexus 9 with 6.0.1 with Google or AOSP Keyboards (doesn't get stocker than that). Long-press shows a few options, including the ones you mentioned and "Save to dictionary". What device are you using specifically? – Tamoghna Chowdhury Jun 15 '16 at 14:32
  • A gentle reminder to include required information (device model). – Andrew T. Aug 13 '16 at 15:57
  • Same here on all my phones. Google took it out from Google Keyboard. – Shiki Jan 21 '17 at 14:25
0

I'm using Galaxy S6 Edge+ from AT&T. Just upgraded to 6.0.1 and DO NOT have a "Save to Dictionary" option.

  • exactly...I am having the same problem... – j4rey Jun 28 '16 at 4:56
  • 2
    So OK, both of you have that issue. But that doesn't mean the feature was removed from MM – there are at least 2 more options: You both use the same device (Galaxy S6 Edge), and Samsung decided to remove that from its ROM – or you both use an ATT device, and MaBell decided to remove it via its branding. So unless there's some link provided to the corresponding changelog entry, we cannot be sure which it is. See also Tamoghna's comment on the question: obviously it's there with MM on the Nexus 9. – Izzy Jun 28 '16 at 11:55
1

I have a Galaxy 7 Edge on Sprint, Android 6.0.1 Marshmallow and had same problem. My fix was to go into Samsung Keyboard (there are no other keyboard choices by default) under Language and Input, and enable Predictive Text, Auto Check Spelling, Auto Replace etc. by choosing English. No language was selected before and these features were disabled. Now a dictionary is being used, and I can remove words from it. To add custom words manually type them, they get added to the dictionary and you can later Swype them and they are used instead of being auto corrected.

0

I found a work-around for not having the Personal Dictionary in Marshmallow.

1: Go to Language and Input

2: Go to Virtual Keyboard

3: Select your keyboard (mine is Samsung Keyboard)

4: Click on Predictive Text, not the On/Off toggle but there is an actual menu if you click on the wording

5: Click on Text shortcuts. This is where you can add your own shortcuts which will come up when your typing.

Hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.