2

I connected my Galaxy S6 to my PC (Windows 7) for the first time. My computer installed the driver successfully and the device is showing under "Removable Storage." When I click on the device from my PC, however, the folder is empty. There are no folders visible at all. I tried the option of automatically importing the pictures, too. I got a message the no pictures were located. I have never had trouble doing this with any other Android phone. I tried a different USB cable, but the result was the same. Thank you for your help.

  • 3
    You have to unlock the phone for it to show any files. This is a security feature on newer Samsung phones to prevent files being accessed when charging at unknown locations. – GiantTree Jun 14 '16 at 14:18
  • 2
    Also you have to swipe down the notification bar and select "MTP" (or labeled slightly different), as I believe the default is "Charge Only". – DukeSilversJazz Jun 14 '16 at 16:32
  • @GiantTree , Not just Samsung phones. I guess anything with MTP enabled from KitKat and up (my Micromax Chinese phone on 4.4.2 has the same behaviour). – Tamoghna Chowdhury Jun 15 '16 at 14:33
5

I just had this problem resolved. On the home screen of your Samsung, pull the notifications menu up by swiping your finger from the top of the screen. Click on USB charging tab. Click on File transfer or Photo transfer. In windows explorer on your computer, click on your device. You will then see your phone details come up.

|improve this answer|||||
0

I wound up going into the Developer options in Settings and changing USB configuration to MTP. It worked fine.

|improve this answer|||||
0

I would agree with Marty L. I recently upgraded my Nokia to a Gallaxy s7, and couldn't figure out why my desktop PC would "see" the phone, but when I clicked on it in the PC's file directory, there were no files or directories shown - just a big blank area where they should be. If you've just gotten a NEW phone, then you'll need to address this challenge in two steps.

First step is, you need to turn ON the Developer Options. This is turned off by default at the factory, and turning it on is a bit of a chore. A blog at Recomhub.com explained it as follows:

"When users turn on and enable developer options on the Samsung Galaxy S7 and Galaxy S7 Edge, you have the ability to control some hidden features that you can change. With Developer Options you can control additional aspects of your device, change settings, or enable USB debugging for advanced functions will need to enable the hidden developer menu in settings."

So to turn on Developer Options, go to Settings>About Phone (all the way at the bottom of the menu list).

After opening "About Phone", you'll see there are a lot of items listed. The item you want to find is called "Build Number". Now here's the bizarre part. Start tapping on the "Build Number" item. After a number of taps, the phone will notify you that it's turning on Developer Options. (Weird. I wonder who came up with that idea......)

Once you've activated the Developer Options, use the "Return" arrow on your phone to back out of the menus until you return to your Settings list. Now when you scroll to the bottom, you'll see a new menu item called "Developer Options" above About Phone.

Now for Step 2. Go into Developer Options menu, and scroll down until you see the "USB configuration" menu item. In smaller letters below that menu item, it should identify the status as "Charging". What that means is that the USB port is only configured to "Charge" at this point, not transfer files. Tap on the USB configuration menu item and change it to "Media Transfer Protocol (MTP)".

Now back out of Settings completely and return to your phone's main screen. You will discover that your PC will now "see" the files on the phone, shown as a "Card" directory (assuming you've added extra memory), and a "Phone" directory. Double clicking on the directories will show you what's stored in each on your phone.

The unfortunate part is this - and others here can correct me if I'm wrong. It seems that every time you hook up your phone to your PC to transfer files via the USB cable, you will need to turn on the MTP again (Step 2 in my instructions). That means you'll need to remember to navigate to the Developer Options menu items in Settings, and scroll down to "USB configuration" and turn on the MTP. A real pain, but it's a security feature, so I guess it's worthwhile. But hopefully, you can save this information to your phone, and just reference it next time you want to transfer files.

To everyone else out there, please comment if I've gotten this wrong.

This was all a little challenging to figure out. The multiple sites I visited each seemed to have pieces of the solution. However the posters invariably left out key steps, or their information was incomplete. I'm hoping my post contains the whole shooting match, and is a help to folks.

|improve this answer|||||
  • I also just got a new S7. After connecting with USB to Win7 or Win10, the phone just pops up with a message asking whether you want to allow your computer access to your device. Click Allow and the files appear. There should be no need to go through Developer options. However, sometimes this popup doesn't appear (and it doesn't if you're not logged into your phone). Disconnecting/connecting again fixes it. More info and solutions: thedroidguy.com/2016/05/… – Abel Oct 31 '17 at 14:06

Not the answer you're looking for? Browse other questions tagged or ask your own question.