0

I have tried everything that was said in the answers below but it just won't work. I want to download an application but whenever I accept the permissions prompt, a notification appears: "Authentication is required. Please sign into your Google Account."

I don't know what to do anymore. Can anyone please help me?

  • Have you tried the obvious? i.e., signing into your Google Account on your phone? If not, then what was the problem? You need to sign into your Google (GMail) account to download apps from the Play Store, it's a prerequisite. – Tamoghna Chowdhury Jun 15 '16 at 14:09
0

Delete your Play Services data.

Go to Settings, Storage, Applictions, and look for Google Play Services. Delete data. Then, go back and scroll until the All tab. Look for Google Play Store. Delete data. Reboot. Enter credentials. Try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.