3

I am using Micromax android one with Android 5.0.1.

Couple of weeks ago, few of my applications stopped one by one. Only two things I was able to do was calling and Whatsapp, probably waiting for their turn to stop. Recently it started showing Unfortunately, com.google.settings has stopped.

I tried to do a Hard Reset. On rebooting itself it started showing Unfortunately, com.google.settings has stopped. And now I am able to do nothing with the phone.

Highly appreciate any help.

  • Clear the dalvik-cache & try again ;) Definitely there's a chance it'll work.. – Gokul NC Jun 20 '16 at 12:15
  • @GokulNC I have done that but no result. – Dhaval Simaria Jun 20 '16 at 13:19
  • you can try and update Google Play Services. It seems like all your Google app ecosystem is not working. Also, in case if you are familiar, try to share adb (android.stackexchange.com/tags/adb/info) logcat output when Settings app crashes. that will help to track down why it is crashing – AADAndroidEnthusiasts Jun 20 '16 at 13:42
  • 1
    FYI, Stock recoveries and Stock ROM zips mutually check file signatures, so one cannot be flashed without the other. – Tamoghna Chowdhury Jun 27 '16 at 14:16
  • 1
    You should use the SP Flash Tools to fish the ROM, not the recovery. I asked you to follow the instructions in the post, and, FYI, you cannot flash a custom ROM zip using the stock recovery, or flash the Stock ROM using a custom recovery. Please exactly follow the post, it will (most probably) work. If it doesn't, then it's a hardware or driver issue. Ensure the PC you flash from has "Enforce Driver Signature Verification" disabled, or "Test Mode" enabled. (Google can help you as to how to do this) – Tamoghna Chowdhury Jun 27 '16 at 14:47
3
+50

A sureshot way to fix this would be to factory reset your device. I understant that you've already tried it from settings while the OS is booted and running. You could try factory resetting it from the stock recovery.

This Google help page will help you with what needs to be done. But do remember - everything in your internal storage will be wiped clean.


Reset device in Recovery mode Before you begin

If your device is running Android 5.1 or higher, your device is protected to prevent other people from using it if it's been reset to factory settings. To ensure that it's really you doing the reset, you'll need to enter a Google username and password associated with the device after factory reset. If you don't have this information, you won't be able to finish the setup process and use the device at all after factory reset.

You'll also need to:

Wait 72 hours if you recently reset your Google account password Make sure you have an Internet connection Back up your data to your Google Account and be ready to restore To do a factory data reset, follow these steps:

  1. If your phone is on, turn it off.
  2. Press and hold the Volume up button and the Power button at the same time until the device turns on.
  3. Press the Volume down button to select "Recovery mode." If you need to navigate to the "Recovery mode" option, use the Volume up button to move the arrow and the Volume down button to select it.
  4. You’ll see an image of an Android robot with a red exclamation mark and the words "No command."
  5. While holding down the Power button, press the Volume up button and release it.
  6. Use the volume buttons to scroll to "wipe data/factory reset" and press the Power button to select it.
  7. Scroll down to "Yes - erase all user data" and press the Power button to select it.

Your Android One device will erase all of your data and restart with its factory settings. You'll see the Welcome screen just as you did when you turned the device on for the first time. When you're done with the setup process, follow these steps to restore your data.

Note: If your phone becomes unresponsive at any point during these steps, you can restart it by holding down the Power button for several seconds. If that doesn’t work, try taking the battery out and putting it back in and starting the steps again.

  • and if none of these works, them flash a new ROM. Easiest way. – Yogesh Jun 27 '16 at 8:18
  • @Yogesh I tried to flash a new stock ROM but it shows the message: Signature Authentication Failure. Process Aborted. I tried it with three different ROMs but same outcome. – Dhaval Simaria Jun 27 '16 at 10:11
  • @Dhaval Flash it using custom recovery like TWRP – Gokul NC Jun 27 '16 at 10:13
  • 1
    @Dhaval, for flashing the Stock ROM, you must use the official stock recovery. First flash the stock recovery using CWM, then use the stock recovery option Install update from SD card to flash the stock ROM zip, if it is recovery-flashable. If it isn't, you'll need to use SP Flash Tools, as mentioned in the XDA post I suggested. – Tamoghna Chowdhury Jun 27 '16 at 14:23
  • 1
    Quick check to see if the zip is recovery-flashable: Open it up in any archiver, e.g. WinRAR, and see if it has a META-INF folder inside it, with a com.google.android folder inside that. If this folder structure exists, the zip is recovery-flashable. Note: Both stock and custom ROM zips have this folder structure if they are recovery-flashable. Ensure what you are flashing is a stock ROM from the stock recovery, or try some CM-based custom ROM from custom recovery (flash via TWRP, CWM is ... unreliable at times). – Tamoghna Chowdhury Jun 27 '16 at 14:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.