1

Ok guys i'm in a real problem!

I cannot make or receive phone calls for one week... it all started when I got bored with the original OS of the HTC One M9, so I rooted the phone and installed CM13 following some tutorial on the internet (its the first time I root and install a custom rom in my life).. when I finished, I was verry happy until I discovered that I cannot make or receive calls, I searched for solutions, and I tried them (installing gapps, uninstalling capps, set phone app as default app...) but none of them worked. So I installed slim roms hoping that this can be the solution, but the same problem is stilling. I installed then android revolution HD and the problem disappeared, it was not solved, it disappeared because this rom didn't event boot. I reinstalled cyanogemod in order to use my phone for things in which it stills usable, and decided to return to the stock rom (the boring one). I found a good tutorial, in which he said that in order to successfully install it i have to:

  • Download the right ruu.
  • Change the cid and the mid.

For the ruu file I found the zip file for the same version used in the tutorial (1.32.401.8). Now when I try to change the cid using this command:

fastboot oem writecid HTC__001

It says:

...
FAILED (remote: unknown command)
finished. total time: 0.006s

After googling it, the problem seems to be caused by 'S-ON', so I have to 'S-OFF' the phone. I downloaded sunshine and run it but the app shows an error saying:

SunShine encountered problems with your rom. Please flash a stock, or more near stock rom and try again

I'm really confused. To install a stock rom i have to change cid. To change cid i have to S-OFF the phone. To S-OFF the phone i have to install a stock rom.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.