3

here is my problem and I feel desperate:

My OnePlus One 64GB does not connect via USB to any PC/Laptop I hook it up to (Windows 7 on Desktop, Laptop). It used to work a long time ago, but not since (I think) Lollipop, needless to say now under Marshmallow. I never managed to root it because of this problem and now cannot even copy files. The only updates I installed are the CM incrementals via OTA.

Android Version: 6.0.1 Cyanogen OS Version: 13.1-ZNH2KAS1KN

It DOES get recognised it the Device Manager though, even if listed as an unknown device (sorry for the German screenshot).

enter image description here

Here is what I have done so far, but nothing worked:

  1. Installed Universal Naked Drivers -> Did not work -> Uninstalled them

    Installed ADB Interface Drivers -> Did not work -> Uninstalled them

    Installed Samsung Drivers -> Did not work -> Uninstalled them

  2. Enabled USB debugging --> Nothing changes. Phone only charges.

  3. Uninstalled any possible driver via device manager (Device Manager -> Unknown device -> Right Click -> Uninstall Drivers)
  4. Using Bacon Root Toolkit: Toolkit did only recognise there was a OnePlusOne, but not its model. AutoDetect did not work either and the highest model version it knows is CM12.1 or so. Updating BRT was successful according to the notification, but did not change anything.
  5. Uninstalled any driver using USBDeview using Bacon Root Toolkit
  6. Looked for USB connection settings (which by the way are not anymore under Settings -> Storage -> Right upper item, but) in Developer Options --> Select USB configuration --> Changed from "Charging" to "MTP"
  7. I have tried different cables and different ports. Neither does it work on my 10 year old Desktop with USB 2.0, nor on my USB 2.0 port on my Laptop or USB 3.0 port.

I am SUPER THANKFUL for any ideas you might have! Thanks in advance!

  • OK, integrated that with your post. Out of ideas then, sorry (I'm no Windows user, so I wouldn't know how to debug things there). Good luck! – Izzy Jun 19 '16 at 13:24
  • What did you end up doing? Found any fix? – CuriousGeorge Nov 30 '17 at 17:23
-1

I also have the same problem and tried whole lot of things, it did not work for me. Now only following things needed to be checked:

  1. Found a comment on the support forum that the Marshmallow CM is having issues with USB to PC connectivity but OTG works.(I haven't tried OTG myself yet but will be definitely check it). So here we need to flash the phone to an older CM version to get the phone detected in hte PC. Reference-> https://forums.oneplus.net/threads/usb-not-working-anymore.453049

  2. It's an hardware issue. The USB ribbon port needs to be changed.

Also please do let us know if you got your problem solved and how.

Thanks.

protected by Community Mar 25 '18 at 19:56

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.