1

So recently rooted my phone, after a few days all google related apps have stopped working and I get the "no connection error". I have looked at so many different tutorials and what not and nothing seems to help.

Ive tried editing the hosts file with file explorers, etc but it fails to save any changes made and it fails to remount to rw.

Ive also tried using adb. Adb root gives me the error that root cannot run in production builds, thus the following basically fails. Using adb pull and trying to push it back does not work, gives me the error that /system is mounted as ro. adb remount, adb mount, doesnt work gives permission denied error.

Im really out of ideas here, its just frustrating to not be able to use playstore, especially receive emails.

Anyone got any ideas? Do I need to flash a custom rom? I read somewhere thats the only way to change permissions since you have to change the kernel build or something, not entirely sure.

Thanks anyways

  • 1
    adb shell, then su and at the root prompt mount -o remount,rw /system doesn't work either? – Izzy Jun 20 '16 at 6:21
  • Did you try ES File Explorer? Just open it, click Options->Tools->Enable 'Root Explorer'. Then click on 'Root Explorer'->Mount R/W->mount /system as 'RW'.. – Gokul NC Jun 20 '16 at 12:23
  • 1
    After mount -o remount,rw /system I get mount : Read-only file system, the next line being 255:root@HWGRA:/ # im not entirely sure what to do beyond this point. – Hawkadeh Jun 20 '16 at 12:27
  • @GokulNC tried ES, FX, root explorer, and some other file explorer I cant remember. – Hawkadeh Jun 20 '16 at 12:28
  • What's your device model? – Thomas Vos Jun 20 '16 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.