Device: Moto X Play Stock (6.0.1) with external SD as portable storage

  • Prior to rooting (recently), transfer both ways (internal and external SD and vice versa was not a problem)

  • After, rooting, it is one way- I can copy files only from external SD card to internal . I am assuming that external SD is not the problem since

    • Device shows external SD, so do various file managers- ES Explorer, Total Commander and all of them fail to do this

    • External SD recognized on laptop and copying / writing is not a problem

  • In Marshmallow, when you need to copy to external SD, you get a notification as below, and in the second pic you expect to see the external SD card listed and you accept- this doesn't happen, there is neither external SD shown nor option to select

enter image description here enter image description here

  • Rooting couldn't or shouldn't have caused this. Further, TWRP option of not allowing modifications to system was chosen

  • I didn't mess with any system tweaks,except for installing Xposed and a few modules (Edit Uninstalled Xposed and behavior is same)

What could be causing this and how to fix it?


  1. I do have access to Mint Linux but practically zero knowledge of commands. If Linux helps in solving this , please be explicit about instructions

  2. There a couple of questions similar but not the same problem and do not help


Solved it by shutting down device, removing external SD card, rebooting a couple of times, inserting external SD and starting the device

It worked but clueless as to what was wrong and what fixed it

I am hoping for a proper explanation/solution to show up

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.