1

My Nexus 4 is soft-bricked, when I turn it on normally it just stays stuck on the "Google" logo. The device has TWRP recovery v2.8.0 installed, which can be accessed. The device's USB does not work, I think it's a hardware problem.

Is there any way to fix a phone in this state? Perhaps send an installable rom zip over Wi-Fi or Bluetooth? I'd be glad to hear any suggestion.

  • Have you tried a factory reset? When did this happen? – Thomas Vos Jun 22 '16 at 17:46
  • How can I do a factory reset? The phone won't boot.. I think it got into this state when I accidentally wiped everything from the phone and didn't have a rom to install. – Roee Hendel Jun 22 '16 at 17:54
  • You can do a factory reset within TWRP. – Thomas Vos Jun 22 '16 at 18:39
  • The problem is, I think I wiped the system partition, so there's nothing installed on the phone right now. I think the only solution would be to send an installable zip. Could it be possible to transfer a file to the device without usb? – Roee Hendel Jun 22 '16 at 18:43
  • Not that I know of without booting the phone. Have you tried connecting it on different computers? What happens when you plug in an OTG cable? – Thomas Vos Jun 22 '16 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.