1

Ordinarily I love the peeking notifications in Marshmallow. They're really useful 95% of the time, and save me a lot of pulling down the notification shade.

But when a real-time game is in the foreground, the heads-up notifications block so much of the screen that they affect my ability to play. I have lost competitive events because of this. Enabling Do Not Disturb, oddly, does not prevent peeking; it only disables the vibration, which doesn't affect my gameplay. (It obviously also disables notification sounds, but my phone spends 99.9% of its life in vibration only mode.)

Obviously I could simply disable peeking, but that's not what I want. I want to suppress peeking only when certain apps are in the foreground. Googling for a solution has been fruitless, either because of keyword confusion or because a solution does not exist. I hope it's the former, and I just haven't been able to put the right query in.

Pretty much any solution is usable for me, since I am on rooted 6.0.1 with Xposed installed.

  • Download macrodroid, give it required permissions, set Trigger--> app launched (your game), actions--> configure app notifications (use toggle all) to select all and disable notifications, constraints none (ignore). I can't test on my MM device as it is not with me ATM. Let me know if it works – beeshyams Jun 23 '16 at 16:26
  • Will the previous notification settings be restored when the game is pushed to the background? – dgw Jun 23 '16 at 16:37
  • They should - but you need to test first. Just in case they don't another simple macro can do the trick – beeshyams Jun 23 '16 at 16:40
  • That's not going to fit my needs, unfortunately. It completely blocks notifications, instead of just disabling peeking. It does not restore the settings when the selected app goes to the background. It also seems unable to quite process all apps on being triggered; a few random apps had their settings unchanged, both in the original macro to disable notifications and in the second one I created to re-enable notifications. – dgw Jun 23 '16 at 16:55
  • Ahh..sorry for that – beeshyams Jun 23 '16 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.