This started like a week ago, my phone wont connect to my WiFi properly.


  • Unable to locate my WiFi (it cant search/ find my WiFi)
  • 'Authentication Problem' shows when it is connecting to the WiFi (there is another one I can't remember)
  • States that 'Internet is unavailable' occasionally when it connects
  • It will connect to WiFi for like 5 secs before dropping again

In the beginning I thought my phone had lost its WiFi range as I would just walk into my office (where my router is) and it would connect, now that is not the case, it is a mixture of the above issues usually simultaneously occurring. It isn't a router issue as my other devices work flawlessly.

*My router emits 2 bands of WiFi (2.4 and 5 GHz) and I've tried using both.

I've tried:

  • Restarting both phone and router
  • Toggling airplane mode, WiFi and Battery Saver
  • Deleting apps prior to the problem

This seems like a common issue within the android community, and I've searched relentlessly for a fix (permanent rather than temporal). If possible I would prefer to not have to factory reset my phone.

Thanks for all the assistance.

  • At this point, I guess a factory-reset won't help you, as it seems to be a system configuration issue. A stock ROM flash would probably help, however. – Tamoghna Chowdhury Jun 25 '16 at 5:08

I have the same exact issue. Literally same exact issue. I got mine to work for a little while after setting my WiFi to broadcast B&G only. I really hope someone finds out how to fix this issue soon. Btw I'm running XDAbbeb's ROM and have tried 3 or 4 others.

Edit: People on the G3 reddit are reporting this issue as well. One user said that replacing the battery fixes the issue.

  • Its sad that this such is a common issue. The battery 'fix' is interesting as I had replaced my battery ~2 months ago, I'll try reverting back to my old battery and see what happens. – Bruh Jun 26 '16 at 7:00
  • Oh btw, reverting back to my old battery allowed me to be able to use my WiFi again (although I literally must be standing next to it). I've done some research and I think that the problem might be due to hardware failure (short circuiting). – Bruh Jul 11 '16 at 9:02

protected by Community Jul 24 '17 at 8:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.