0

My Samsung S4 mini won't turn on past the Samsung logo screen. I've tried holding down the down power and menu button at the same time and clearing the cache partition thing and rebooting it from there and still nothing......pls help. :'(

EDIT* I believe my battery is a good one. I've had the phone for 2 years and never replaced the battery. however, I saw that the batteries have a life span of about 2 to 3 years. But II did the spin test which involves putting your battery on a flat surface and tapping the corners and if it spins the battery isn't good.

  • What carrier do you have? I can link all the files, as well as a detail tutorial, if I know this. Also you will most likely have to flash your phone to stock. Unfortunately this means you will lose your data :( – asloss Jun 24 '16 at 12:57
0

Thats called a bootloop (i like the word ). Its usually caused by an error when updating the firmware. I fixed it by flashing the firmware on it again with odin. However your data is lost.

  • It's not necessarily lost... In some cases you can recover at least parts of it via ADB – Namnodorel Jun 27 '16 at 20:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.