When trying to connect to a WPA2 network from an HTC Hero running 2.1, I can't connect if the hidden SSID has a space in the name.

Has anyone else encountered this problem? Is it known to be an Android issue?

  • It's not so convenient that HTC phones have 'HTC Network' as the default, is it? ;) – gary Sep 25 '10 at 0:24
  • I've never had this problem on my android device (note3) but my wife and daughter's iphone 6 and 6s couldn't connect when there was a space in the ssid. I changed the ssid to have no spaces and they could connect perfectly (Nov'17). – Chillywinter Nov 27 '17 at 8:50

Yes and yes. http://code.google.com/p/android/issues/detail?id=8035

I haven't seen any resolution to this except changing the router's SSID if you have access to it.

  • Thanks! I hunched the space was the problem and ended up changing the SAID, but was never sure it was really a bug with Android or not. – BrianCooksey Sep 24 '10 at 12:09
  • Its not so bad when its your AP and can change it but they really need to fix thnugbug. – Matt Sep 24 '10 at 12:17
  • Fortunately the AP I was having a problem with had a guest SSID option. We just added the second SSID and were able to connect without affecting the other established users. – BrianCooksey Sep 24 '10 at 14:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.